Contributor
Contributor

Move-VM cmdlet with datastore cluster

Hi,

I'm attempting cross vCenter migration of VMs using Move-VM PowerCLI cmdlet.

Migration to a datastore works fine.

Migration to a datastore cluster fails.

Is this a known limitation of move-VM cmdlet?

Thanks.

Tags (2)
0 Kudos
4 Replies
Leadership
Leadership

Which PowerCLI version are you using?

The Move-VM cmdlet help states it is supported.

Are you getting any errors?


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos
Contributor
Contributor

Thanks for the reply Luc.

move-vm : 15/10/19 3:42:41 pm Move-VM When migrating a VM to a different vCenter Server both Destination and Datastore need to be specified. No other destination types but VMHost/Resource Pool and Datastore are supported for Cross vCenter vMotion

PowerCLI Version

----------------

   VMware PowerCLI 11.2.0 build 12483598

---------------

Component Versions

---------------

   VMware Cis Core PowerCLI Component PowerCLI Component 11.2 build 12483642

   VMware VimAutomation VICore Commands PowerCLI Component PowerCLI Component

11.2 build 12483638

   VMware VimAutomation Vds Commands PowerCLI Component PowerCLI Component

11.2 build 12483615

At the moment workaround is the following passed to move-vm datastore option

-datastore (get-datastorecluster -server $dst_vc $datastore_cluster | get-datastore | sort-object -property FreeSpaceMB -descending | select -first 1)

0 Kudos
Leadership
Leadership

The latest PowerCLI releases (currently 11.4) did include some Move-VM changes.
It might be worth trying an upgrade.

If that doesn't help, I would still suggest opening an SR.
At least the help page for Move-VM is incorrect.


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos
Contributor
Contributor

Upgraded but still have the same issue.

Thanks for suggestions.

0 Kudos