Gael
Contributor
Contributor

How to test script portability before update?

Hi,

Is it possible to test scripts compatibility before an update of PowerCli from 5.8 to 6.5.x ?

At worst, command are deprecated, isn't it?

 

Thanks,

0 Kudos
1 Reply
LucD
Leadership
Leadership

There is no 'utility' for that afaik.

What you can do is to allow the DepreciationWarnings and then run the script in the old release.

With these warnings you can now check the PowerCLI change log of all releases since your old release, and check if anything mentions the actual removal of a deprecated component.


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos