PowerRails
Contributor
Contributor

Get-SpbmStoragePolicy Issue

Hi,

 

We rely on PowerCLI to automate some of the tasks we need to perform and the Get-SpbmStoragePolicy seems broken.

 

 

ERROR:

PS /home/perfuser/vxbench> Get-SpbmStoragePolicy
Get-SpbmStoragePolicy : 1/27/21 9:11:42 AM Get-SpbmStoragePolicy com.vmware.vapi.std.errors.operation_not_found {'messages': [com.vmware.vapi.std.localizable_message {'id': vapi.method.input.invalid.interface, 'default_message': Cannot find service 'com.vmware.cis.data.svc.resource_model'., 'args': [com.vmware.cis.data.svc.resource_model]}], 'data':}
At line:1 char:1
+ Get-SpbmStoragePolicy
+ ~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [Get-SpbmStoragePolicy], CisException
+ FullyQualifiedErrorId : VMware.VimAutomation.ViCore.Impl.V1.Service.Tagging.Cis.TaggingServiceCisImpl.GetTag.Error,VMware.VimAutomation.Storage.Commands.Cmdlets.Spbm.GetStorageProfile

 

 

ENV DETAILS:

 

PS /home/perfuser/vxbench> Get-PowerCLIVersion
WARNING: The cmdlet "Get-PowerCLIVersion" is deprecated. Please use the 'Get-Module' cmdlet instead.

PowerCLI Version
----------------
VMware PowerCLI 11.1.0 build 11289667
---------------
Component Versions
---------------
VMware Cis Core PowerCLI Component PowerCLI Component 11.0 build 10335701
VMware VimAutomation VICore Commands PowerCLI Component PowerCLI Component 11.0 build 10336080
VMware VimAutomation Storage PowerCLI Component PowerCLI Component 11.1 build 11273342

 

Please help us.

 

Thanks

0 Kudos
6 Replies
LucD
Leadership
Leadership

That is a known issue I'm afraid, see also Get-SpbmStoragePolicy and Get-Tag Issues, again - VMware Technology Network VMTN

I would suggest opening an SR.


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos
PowerRails
Contributor
Contributor

Thank you LucD !

 

I will see if I can open a SR.

Could you tell me if there is already a SR number where that issue has been reported to support ?

I think I am not the only one having this problem and this is a very common method used for VSAN.

 

Thanks again for the quick reply.

0 Kudos
PowerRails
Contributor
Contributor

*** ALL CLEAR ***

 

Updated to latest PowerCLI version and everything works fine now.

 

PS /root> Get-PowerCLIVersion
WARNING: The cmdlet "Get-PowerCLIVersion" is deprecated. Please use the 'Get-Module' cmdlet instead.

PowerCLI Version
----------------
VMware PowerCLI 12.1.0 build 17009493
---------------
Component Versions
---------------
VMware Common PowerCLI Component 12.1 build 16997174
VMware Cis Core PowerCLI Component PowerCLI Component 12.1 build 16997582
VMware VimAutomation VICore Commands PowerCLI Component PowerCLI Component 12.1 build 16997984

 

PS /root> Get-SpbmStoragePolicy

Name Description Rule Sets Common Rules
---- ----------- --------- ------------
Management Storag... Management Storage policy used for... {(VSAN.hostFailuresToTolera... {}

 

 

Thanks

0 Kudos
LucD
Leadership
Leadership

I'm afraid I don't have an SR number.

Should GSS claim that you need Developer Support to be able to open an SR for PowerCLI, that is not correct.
Point them to PowerCLI Support Breakdown


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

LucD
Leadership
Leadership

Strange, that is in fact the version the other thread was using.

But good it solved your issue.


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos
PowerRails
Contributor
Contributor

I forgot to mention an important point.

My ENV is a Beta release (VC+ESXi).

Something might have changed on the latest beta that broke that API and needs the latest PowerCLI version.

0 Kudos