VMware Cloud Community
venugs
Enthusiast
Enthusiast
Jump to solution

Get-DatastoreCluster : Error in operation 'RetrievePropertiesEx'

Hello Members,

Need support with the below error while using Get-DatastoreCluster

PowerCLI version  : VMware PowerCLI 12.2.0, updated and tried VMware PowerCLI 12.5.0 both reported same error.

Error in deserializing body of reply message for operation 'RetrievePropertiesEx'

The command error's out after listing 23 DataStoreCluster Names. [The Name Length of Each DataStore Cluster ~22-25 Characters if that helps.]

 

Complete error:

Get-DatastoreCluster : 1/21/2022 9:10:00 AM Get-DatastoreCluster Error in deserializing body of reply message for operation 'RetrievePropertiesEx'.
At line:1 char:1
+ Get-DatastoreCluster
+ ~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [Get-DatastoreCluster], ViError
+ FullyQualifiedErrorId : Client20_QueryServiceImpl_RetrievePropertiesEx_ViError,VMware.VimAutomation.ViCore.Cmdlets.Commands.GetDatastoreCluster

Any workarounds/support for the issue.

Thank you

Venu

Reply
0 Kudos
1 Solution

Accepted Solutions
LucD
Leadership
Leadership
Jump to solution

That might be a bug/issue in the VCSA DB.
Can you recreate the DatastoreCluster?

In any case, I suggest opening an SR.


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

View solution in original post

6 Replies
LucD
Leadership
Leadership
Jump to solution

That is a rather general error that has been seen on occasions.

Some things you can try:

- Stop/start your PS/PowerCLI session

connect to the vCenter with a FQDN

- reboot your station (?)


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

Reply
0 Kudos
venugs
Enthusiast
Enthusiast
Jump to solution

Hello ,

Thanks for your reply,

I have seen your earlier replies on similar problems and  have done all the three steps suggested by you.

I have no luck in my case, what are the possibilities that it could be with a specific DatastoreCluster that doesn't want to return the information for the Query.

Thank you

Venu

 

Reply
0 Kudos
LucD
Leadership
Leadership
Jump to solution

Did you try to isolate the DatastoreCluster?
Is it always the same one?


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

Reply
0 Kudos
venugs
Enthusiast
Enthusiast
Jump to solution

Yes, i was able to, sorry i missed to add this information in my earlier reply.

Since we have around 25 DatastoreClusters, this happens only on one DatastoreCluster and the Command Terminates.

PS C:\> Get-DatastoreCluster <Problematic DatastoreCluster>
Get-DatastoreCluster : 1/1/2022 12:00:00 AM    Get-DatastoreCluster Error in deserializing body of reply message for operation 'RetrievePropertiesEx'.
At line:1 char:1
+ Get-DatastoreCluster <Problematic DatastoreCluster>
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Get-DatastoreCluster], ViError
    + FullyQualifiedErrorId : Client20_QueryServiceImpl_RetrievePropertiesEx_ViError,VMware.VimAutomation.ViCore.Cmdlets.Commands.GetDatastoreCluster

Get-DatastoreCluster : 1/1/2022 12:00:00 AM    Get-DatastoreCluster  DatastoreCluster with name
'<Problematic DatastoreCluster>' was not found using the specified filter(s).
At line:1 char:1
+ Get-DatastoreCluster <Problematic DatastoreCluster>
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : ObjectNotFound: (:) [Get-DatastoreCluster], VimException
    + FullyQualifiedErrorId : Core_OutputHelper_WriteNotFoundError,VMware.VimAutomation.ViCore.Cmdlets.Commands.GetDatastoreCluster
Reply
0 Kudos
LucD
Leadership
Leadership
Jump to solution

That might be a bug/issue in the VCSA DB.
Can you recreate the DatastoreCluster?

In any case, I suggest opening an SR.


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

venugs
Enthusiast
Enthusiast
Jump to solution

Thank you for your time in looking into the issue, we would have an SR raised!

Regards,

Venu

Reply
0 Kudos