wcpoon83
Contributor
Contributor

Failed to Import VMware.VimAutomation.vROps Module

Hi,

I failed to import modue for VMware.VimAutomation.vROps, below is the error,

Import-Module -Name VMware.VimAutomation.vROps -Force                                                                                                                                                                                                      Exception: VMware.VimAutomation.vROps module is not currently supported on the Core edition of PowerShell.

My powerCLI version is 11.5.0 build 14912921 

Is it my powerCLI version not supported vROps module version 10.0 ?

Please advise.

0 Kudos
3 Replies
LucD
Leadership
Leadership

You seem to be running this on a Linux or MacOS platform.

The vROps is currently indeed not supported on that type of platform, only on a Windows platform.


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos
wcpoon83
Contributor
Contributor

Hi,

Yes, running in Ubuntu. If running in Windows, it will not have this issues?

0 Kudos
LucD
Leadership
Leadership

Provided you are using PowerShell 5.1 on that Windows platform.


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos