Akopylov
Commander
Commander

DistributedVirtualSwitchInfo with id 'xxx' does not exist

Jump to solution

Hello there.

I am trying to create vmk intarfaces with New-VMHostNetworkAdapter cmlet, but gettin the error "DistributedVirtualSwitchInfo with id 50 02 5a 5c 8c fc 30 be-15 99 73 74 7d 87 b7 37' does not exist."

I've tried to specify vDS name in the cmdlet, tried to specify the variable, in which the switch object was stored (the result of Get-VirtualSwitch and Get-VDSwitch cmdlets), but still no luck.

Furthermore, the vDS key is the same, vCenter is complaining about:

PS C:\Windows\system32> $vswitch.key

50 02 5a 5c 8c fc 30 be-15 99 73 74 7d 87 b7 37

What is the problem?

0 Kudos
1 Solution

Accepted Solutions
LucD
Leadership
Leadership

Did you already stop/start your PS session?

Which PS, PCLI and vSphere version are you using?

Does it work from the Web Client?


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

View solution in original post

0 Kudos
2 Replies
LucD
Leadership
Leadership

Did you already stop/start your PS session?

Which PS, PCLI and vSphere version are you using?

Does it work from the Web Client?


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

View solution in original post

0 Kudos
Akopylov
Commander
Commander

Eh, I'm sorry for the stupid issue.

The single vmhost was configured manually from the Web Client successfully, but I forgot to migrate other hosts to this particular vDS (hosts in this nested lab should participate in 2 vDS).

Thanks for the help.

0 Kudos