AlexAckerman
Enthusiast
Enthusiast

Deploying VApp From Content Library via PowerCLI Issues

Jump to solution

So this was originally posted under the Workspace ONE discussions since it was for the Workspace ONE Access appliance.  However, after a bit of testing, it looks to be more of a PowerCLI handling of OVF Configurations between New-VM and Import-VApp.  The original post is here:

https://communities.vmware.com/t5/Workspace-ONE-Discussions/Workspace-ONE-Access-OVF-Deployment-via-...

Short summary:

I'm trying to import a VApp using a PowerCLI script that can either take a file location on the local system or a VApp that has been saved to a Content Library.  The Import-VApp line works as expected once you configure the OVF Configuration and the resulting VM has the following settings configured:

vApp Options from vapp-import.png

 

However, when I use New-VM to pull the same OVA stored in a Content Library, none of the associated network configuration settings survive the import as shown here:

vApp Options.png

 

It's interesting that the Timezone setting and host name configurations do make it through.  What is going on between how these two commands handle the VApp import? 

Thanks!

Ack

Labels (3)
1 Solution

Accepted Solutions
LucD
Leadership
Leadership

I can confirm.
I suggest opening an SR


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

View solution in original post

6 Replies
LucD
Leadership
Leadership

Which PowerCLI version are you using?


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos
AlexAckerman
Enthusiast
Enthusiast

12.4.1.  Fresh pull from the PowerShell Gallery to a new machine. 

0 Kudos
LucD
Leadership
Leadership

I can confirm.
I suggest opening an SR


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

AlexAckerman
Enthusiast
Enthusiast

Idea submitted here: https://powercli.ideas.aha.io/ideas/PCLI-I-364

Is there another place to submit that would be better?

Thank you for the assistance.

Ack

LucD
Leadership
Leadership

No, that is the right place.

If you have a Support Contract, I would in any case also open an SR.


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos
AlexAckerman
Enthusiast
Enthusiast

Unfortunately no support contract.  I'm using my VMUG account and working with this in my Homelab.  Thank you for the assistance!

Ack

0 Kudos