Highlighted
Expert
Expert

Clone_VM + CustomizationIPSettings + dnsServerList

Jump to solution

I am having an issue with the customization of windows 2008R2 guest.

When i specify for my dnsServerlist one dns sever, then there is no problem for the guest to get that specific dns entry.

But when i specify 2 dns servers like so: 192.168.0.2,192.168.0.2 then no DNS settings are being applied.

Is my syntax still correct? It use to work with 3.5 without any problems.

0 Kudos
1 Solution

Accepted Solutions
Highlighted
User Moderator
User Moderator

You could try with @("192.168.0.1","192.168.0.2"), but I don't expect that to make a lot of difference.

____________

Blog: LucD notes

Twitter: lucd22


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

View solution in original post

0 Kudos
10 Replies
Highlighted
User Moderator
User Moderator

Are you using the New-OSCustomizationSpec cmdlet or are you using the CustomizationSpec object from the SDK ?

____________

Blog: LucD notes

Twitter: lucd22


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos
Highlighted
Expert
Expert

Luc,

I am using the CustomizationSpec from the SDK.

I just tweaked our Windows 2008R2 template, to completely disable IPv6

0 Kudos
Highlighted
User Moderator
User Moderator

The dnsServerList property hasn't changed.

You still provide an array of strings, where each element conatins the IP address of 1 DSNserv.

Could be that the "sysprep" part has problems with W2K8r2.

Anything in the vpdx logs ?

Perhaps set the logging level to "verbose" first.

____________

Blog: LucD notes

Twitter: lucd22


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos
Highlighted
Expert
Expert

I looked at the logs on the client, no errors.

I already have the logging level set to verbose.

The only string i provide is: 192.168.0.1,192.168.0.2 for the DNS settings.

Another case i tested was using the customization specification, and that didn't give any problems.

0 Kudos
Highlighted
User Moderator
User Moderator

You could try with @("192.168.0.1","192.168.0.2"), but I don't expect that to make a lot of difference.

____________

Blog: LucD notes

Twitter: lucd22


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

View solution in original post

0 Kudos
Highlighted
Expert
Expert

i also tryed adding 34 at the beginning and end of the strings, but that didn't helped me

I am now also checking if the same problem exists for the gateway propertie, which can also be a list

0 Kudos
Highlighted
Expert
Expert

Gateway has the same issues.

I will try the array option.

0 Kudos
Highlighted
Expert
Expert

Hi Luc,

Giving an array as a option for DNS worked!!

I think i can call this a feature, before Update 1 the guirunonce option would completely crash the vCenter server service.

0 Kudos
Highlighted
User Moderator
User Moderator

Strange indeed. I think I will have to do some testing as well Smiley Wink

Will the "feature" still be there after Update 2 ?

____________

Blog: LucD notes

Twitter: lucd22


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos
Highlighted
Expert
Expert

We will see.

It keeps us of the street.

0 Kudos