wmallen3
Contributor
Contributor

Adding VAAI support to Dell Compellent

Hello

I want to install VAAI suuport for the Dell Compellent.

The documnet states to install the plugin and reboot.

After the reboot run these commands

***************************************************

esxcli corestorage claimrule add --claimrule-class=Filter --plugin=VAAI_FILTER --type=vendor --vendor=COMPELNT --autoassign

#esxcli corestorage claimrule add --claimrule-class=VAAI --plugin=DELL_VAAIP_COMPELLENT --type=vendor --vendor=COMPELNT --autoassign

#esxcli corestorage claimrule load --claimrule-class=Filter

#esxcli corestorage claimrule load --claimrule-class=VAAI

#esxcli corestorage claimrule run --claimrule-class=Filter

#esxcli corestorage claimrule list --claimrule-class=Filter

#esxcli corestorage claimrule list --claimrule-class=VAAI

****************************************************

Having a hard time converting options to CLI.

Just need the proper format for the options.

$esxcli = Get-EsxCli
$esxcli.corestorage.claimrule.add (-c --Filter -P --VAAI_FILTER -V --COMPELNT -u)
$esxcli.corestorage.claimrule.add (-c --VAAI -P --DELL_VAAIP_COMPELLENT -V --COMPELNT -u)
$esxcli.corestorage.claimrule.load (-c --Filter)
$esxcli.corestorage.claimrule.load (-c --VAAI)
$esxcli.corestorage.claimrule.run (-c --Filter)

$esxcli.corestorage.claimrule.list(-c --Filter)
$esxcli corestorage claimrule list(-c --VAAI)

Thank you in advance !!!

0 Kudos
3 Replies
LucD
Leadership
Leadership

Did you already try the method used in Esx >4.x  Communication with Storage changed


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos
wmallen3
Contributor
Contributor

Looking now

William Allen

Sr. Network Engineer

Ph: (704) 426-8857

0 Kudos
wmallen3
Contributor
Contributor

LucD...I think I figured out the options.

$esxcli.corestorage.claimrule.add($null,"autoassign",$null,"Filter",$null,$null,$null,$null,$null,"VAAI_FILTER",$null,$null,$null,"vendor","COMPELNT")

$esxcli.corestorage.claimrule.add($null,"autoassign",$null,"VAAI",$null,$null,$null,$null,$null,"DELL_VAAIP_COMPELLENT",$null,$null,$null,"vendor","COMPELNT")

$esxcli.corestorage.claimrule.load('Filter')
$esxcli.corestorage.claimrule.load('VAAI')

$esxcli.corestorage.claimrule.run($null,$null,"Filter",$null,$null,$null,$null,$null,$null)

$esxcli.corestorage.claimrule.list('Filter')
$esxcli.corestorage.claimrule.list('VAAI')

When I run the ADD statements I get "The remote server returned an error: (500) Internal Server Error."

I saw something in that post about a bug. Was this the bug?

0 Kudos