seannewbie
Contributor
Contributor

there is no distributed port-group for selection when configuring Edge L2 bridging

Jump to solution

Dear all,

I am trying to configure L2 bridging using NSX Edge, I can select logical switch, but it does not allow me to select port group. I did have configured distributed port group already.

Figure 1: It allowes me to select a logical switch, but no distributed port group.

Nothing to select.JPG

Figure2: the pop-up window shows nothing after I click on Select... button

0 distributed port-group.JPG

Figure 3: my topology

top.JPG

0 Kudos
1 Solution

Accepted Solutions
seannewbie
Contributor
Contributor

ah oh, I made a mistake...I did not assign a VLAN number to the vlan port-group. The edge can only work for VXLAN-VLAN pair in this scenario.

Thanks for your time and support.

View solution in original post

0 Kudos
5 Replies
Sreec
VMware Employee
VMware Employee

How many Distributed switch you have in this setup ? Ensure your VLAN port-groups are in same DVS which is prepared for VXLAN.

Cheers,
Sree | CKA|CKAD|VCIX-3X| VCAP-4X| VExpert 5x
0 Kudos
seannewbie
Contributor
Contributor

Sir, thank you.

Totally I have 2 DVs, one is for management (initially the whole environment used the default manage network which is powered by a primitive standard vSwitch,  then it was migrated to a DV), the other one is created for configuring the logical switch and the vlan port-group. So, yes, the logical switch which possess the vxlan and the vlan port-group are on the same distributed switch.

Sir, I wanna know why a switch named none showing up... and the vm NSX Edge is connected to it. Simultaneously the vm NSX Edge is connected to the management VD named MGR-VDS.

The vlan port-group and the logical switch named LogicalSW1 are on the same VDS named VXLAN-VDS as shown following.

switch none.JPG

0 Kudos
Sreec
VMware Employee
VMware Employee

Is the edge connected to VXLAN-VDS ?

Cheers,
Sree | CKA|CKAD|VCIX-3X| VCAP-4X| VExpert 5x
0 Kudos
seannewbie
Contributor
Contributor

no sir, it just connected to the MGR-VDS as I think it is just a part of controller.  Should it be connected to the VXLAN-VDS? which port-group may I ask?

0 Kudos
seannewbie
Contributor
Contributor

ah oh, I made a mistake...I did not assign a VLAN number to the vlan port-group. The edge can only work for VXLAN-VLAN pair in this scenario.

Thanks for your time and support.

View solution in original post

0 Kudos