Contributor
Contributor

"No mapping found" issue for API request

I am a new hire, and prototyping an test API to get familiar with the flow. Now I ran into an error "No mapping found" when I tested my local build, I even got the same error when querying our product API, like /api/v1/license. following is what I did. am I missing anything or any idea why the api path becomes "/nsxapi/api/v1/blabla" ? thank you for your input.

1. implemented a test API

2. built locally at <root>/git/nsx/mp

3. set up a test bed, that has minimum set up including only one manager node and one CCP Node

4. copied local built proton-1.0.war to manager host as /opt/vmware/proton-tcserver/webapps/nsxapi.war

5. restarted proton service in manager node

6. query the test api via postman, then got an error saying "Application is not ready" from a module named "common-services"

7. looked at the nsxapi.log in manager host, found following error msg

2015-07-29 18:22:05.929 UTC  WARN http-nio-127.0.0.1-7440-exec-1 ?: - No mapping found for HTTP request with URI [/nsxapi/api/v1/license] in DispatcherServlet with name 'spring'

0 Kudos
0 Replies