YehonatanLT12
Contributor
Contributor

fail to create NSX Controller

Jump to solution

Hi, I'm try to create an NSX Controller, but every time it's fail and say that U don't have enough memory but I increasd the memory and the storage and every time I get this error message:

VMPowerOnException: core-services:1502:Failed to power on VM SA-Cluster-NSX-controller-7: The host does not have sufficient memory resources to satisfy the reservation..:The host does not have sufficient memory resources to satisfy the reservation.

If someone have any idea how to fix it I'll be very thankfull.

nsx.png

1 Solution

Accepted Solutions

Change the deafult reservation from NSX Manager to avoid the reservation for the controllers.

You can do this changing this parameter using an API Call:

https://docs.vmware.com/en/VMware-NSX-Data-Center-for-vSphere/6.2/nsx_62_api.pdf

You can follow this blog if you never used this before: https://rutgerblom.com/2019/06/16/getting-started-with-the-nsx-t-api-and-postman/

Do this:

GET https://NSX-Manager-IP-Address/api/4.0/edgePublish/tuningConfiguration

Response Body:

<tuningConfiguration>

<lockUpdatesOnEdge>false</lockUpdatesOnEdge>

<aggregatePublishing>true</aggregatePublishing>

<edgeVMHealthCheckIntervalInMin>0</edgeVMHealthCheckIntervalInMin>

<healthCheckCommandTimeoutInMs>120000</healthCheckCommandTimeoutInMs>

<maxParallelVixCallsForHealthCheck>25</maxParallelVixCallsForHealthCheck>

<publishingTimeoutInMs>1200000</publishingTimeoutInMs>

<edgeVCpuReservationPercentage>100</edgeVCpuReservationPercentage>

<edgeMemoryReservationPercentage>100</edgeMemoryReservationPercentage>

<megaHertzPerVCpu>1000</megaHertzPerVCpu>

</tuningConfiguration

Then you do a PUT, to change the configuration (Highligted in red)

PUT https://NSX-Manager-IP-Address/api/4.0/edgePublish/tuningConfiguration

Response Body:

<tuningConfiguration>

<lockUpdatesOnEdge>false</lockUpdatesOnEdge>

<aggregatePublishing>true</aggregatePublishing>

<edgeVMHealthCheckIntervalInMin>0</edgeVMHealthCheckIntervalInMin>

<healthCheckCommandTimeoutInMs>120000</healthCheckCommandTimeoutInMs>

<maxParallelVixCallsForHealthCheck>25</maxParallelVixCallsForHealthCheck>

<publishingTimeoutInMs>1200000</publishingTimeoutInMs>

<edgeVCpuReservationPercentage>0</edgeVCpuReservationPercentage>

<edgeMemoryReservationPercentage>0</edgeMemoryReservationPercentage>

<megaHertzPerVCpu>1000</megaHertzPerVCpu>

</tuningConfiguration

They do the controller provision again and should work

Cheers

N

Triple VCIX (CMA-NV-DCV) | vExpert | MCSE | CCNA

View solution in original post

0 Kudos
9 Replies
Sreec
VMware Employee
VMware Employee

You need to adjust your vsphere HA settings to fix this issue . VMware Knowledge Base

Cheers,
Sree | CKA|CKAD|VCIX-3X| VCAP-4X| VExpert 5x
Please KUDO helpful posts and mark the thread as solved if answered
0 Kudos
YehonatanLT12
Contributor
Contributor

The error message still appear every time I try... do you have any other idea?

0 Kudos
YehonatanLT12
Contributor
Contributor

Maybe that connection to that the NSX not on the shared storage?

0 Kudos
daphnissov
Immortal
Immortal

Remove the memory reservation on this VM.

0 Kudos

Change the deafult reservation from NSX Manager to avoid the reservation for the controllers.

You can do this changing this parameter using an API Call:

https://docs.vmware.com/en/VMware-NSX-Data-Center-for-vSphere/6.2/nsx_62_api.pdf

You can follow this blog if you never used this before: https://rutgerblom.com/2019/06/16/getting-started-with-the-nsx-t-api-and-postman/

Do this:

GET https://NSX-Manager-IP-Address/api/4.0/edgePublish/tuningConfiguration

Response Body:

<tuningConfiguration>

<lockUpdatesOnEdge>false</lockUpdatesOnEdge>

<aggregatePublishing>true</aggregatePublishing>

<edgeVMHealthCheckIntervalInMin>0</edgeVMHealthCheckIntervalInMin>

<healthCheckCommandTimeoutInMs>120000</healthCheckCommandTimeoutInMs>

<maxParallelVixCallsForHealthCheck>25</maxParallelVixCallsForHealthCheck>

<publishingTimeoutInMs>1200000</publishingTimeoutInMs>

<edgeVCpuReservationPercentage>100</edgeVCpuReservationPercentage>

<edgeMemoryReservationPercentage>100</edgeMemoryReservationPercentage>

<megaHertzPerVCpu>1000</megaHertzPerVCpu>

</tuningConfiguration

Then you do a PUT, to change the configuration (Highligted in red)

PUT https://NSX-Manager-IP-Address/api/4.0/edgePublish/tuningConfiguration

Response Body:

<tuningConfiguration>

<lockUpdatesOnEdge>false</lockUpdatesOnEdge>

<aggregatePublishing>true</aggregatePublishing>

<edgeVMHealthCheckIntervalInMin>0</edgeVMHealthCheckIntervalInMin>

<healthCheckCommandTimeoutInMs>120000</healthCheckCommandTimeoutInMs>

<maxParallelVixCallsForHealthCheck>25</maxParallelVixCallsForHealthCheck>

<publishingTimeoutInMs>1200000</publishingTimeoutInMs>

<edgeVCpuReservationPercentage>0</edgeVCpuReservationPercentage>

<edgeMemoryReservationPercentage>0</edgeMemoryReservationPercentage>

<megaHertzPerVCpu>1000</megaHertzPerVCpu>

</tuningConfiguration

They do the controller provision again and should work

Cheers

N

Triple VCIX (CMA-NV-DCV) | vExpert | MCSE | CCNA

View solution in original post

0 Kudos
YehonatanLT12
Contributor
Contributor

I have NSX-V, have any different between NSX-V to NSX-T in postman installation?

0 Kudos
YehonatanLT12
Contributor
Contributor

To the VM don't have any reservation

0 Kudos

It is the same... just download postman or any other client and run the GET and PUT shared above

Triple VCIX (CMA-NV-DCV) | vExpert | MCSE | CCNA
MostafaElSayedF
Enthusiast
Enthusiast

Did you try simply to move it to another host and try to power it on? I was having similar issue previously and when I move the controller to different host it work normally.

I hope this answer your question and i hope that this become answer or helpful comment for you. also, for More details and more information just follow my blog https://www.syncgates.com Mostafa Fahmy
0 Kudos