Joey2008
Contributor
Contributor

You have reached the maximum number of connected consoles (DLR & ESG)

Jump to solution

Hi All,

I got this issue all the time, from VCenter, I can log in by right click "open console" to DLR or ESG normally, but if I forgot to log off, next time I won't be able to log in console any more, it always show me as below. Every time I have to reboot the DLR/ESG VMs, where/how to fix this? Thanks ahead.

A server error occurred.

You have reached the maximum number of connected consoles: 1. Please contact your administrator.

Check the vSphere Web Client server logs for details.

1 Solution

Accepted Solutions
Sreejesh_D
Virtuoso
Virtuoso

I think I had the similar issue. When I try to grab console of a VM it throws the same error ' you have reached ...'.

Try this first.

1. open a private / incognito window in your browser.

2. Login to vcenter and connect to the console.

If it works, clear cookies, history, etc. And try accessing the console again.

View solution in original post

4 Replies
Sreejesh_D
Virtuoso
Virtuoso

I think I had the similar issue. When I try to grab console of a VM it throws the same error ' you have reached ...'.

Try this first.

1. open a private / incognito window in your browser.

2. Login to vcenter and connect to the console.

If it works, clear cookies, history, etc. And try accessing the console again.

Joey2008
Contributor
Contributor

Hi Yezdi,

U rock!

I always assumed this is an issue from DLR/ESG, like Cisco router, if you don't configure vty time-out, and if you keep logging in and not exit properly, you will use up all vty sessions (8 or so), then you can not telnet/ssh in anymore.

BUT, this issue is not that, it is browser issue, if you close off the browser completely, it will be fine. - I always do relogin, which had the previous login session in cache, which blocked me to console in.

Thanks again!!!!!!!!

Joey2008

0 Kudos
rajeevsrikant
Expert
Expert

Check under the VMware Remote Control Options for both the Edge & the DLR.

By Default Maximum no of sessions allowed is 1.

That is the reason you are getting this error message.

Below is the screen shot for your reference.

pastedImage_0.png

Joey2008
Contributor
Contributor

Hi Raj,

I noticed this option too, but how can I modify it? the EDIT is grayed out for DLR/ESG, it is editable for Windows VMs. I tried to shutdown DLR, no change.

0 Kudos