MillardJK
Enthusiast
Enthusiast

Web Client lockup with Edge Certificate

Jump to solution

I just upgraded my environment to 6.4.1, and am trying to update the certificate being used by an Edge that's providing SSL VPN Plus services. Unfortunately, every time I go to the edge and select Manage->Settings->Certificates, I get the 'greyed out' Flash/Flex "refresh" and the client locks up. This happens with every browser I've tried (that will run a version of Flash, that is) and several different systems, even after flushing cache, etc.

First, I'd like to know if I've got an isolated environment that's to blame (please: someone reproduce this!)

Second, if anyone has a work-around to get this working, it would be appreciated.

——
Jim Millard
Kansas City, MO USA
1 Solution

Accepted Solutions
mdac
Enthusiast
Enthusiast

This is a known problem in 6.3.6 and 6.4.1, unfortunately. KB 56389 discusses this:

VMware KB 56389

If any certificates have <certificateType> being NULL, this hang occurs. The KB discusses a workaround that can be done via REST API.

Hope this helps.

My blog: https://vswitchzero.com Follow me on Twitter: @vswitchzero

View solution in original post

5 Replies
dot111q
Contributor
Contributor

I have exact the same problem in my lab environment.

I have tried to reinstall nsx plugin from scratch. I have tried to clear SerenityDB. No luck( No ideas how to fix(

I found this error appear in /var/log/vmware/vsphere-client/logs/vsphere_client_virgo.log just before webclient lockout:

[2018-06-30T21:16:26.425Z] [ERROR] http-bio-9090-exec-7         70001751 100124 200114 com.vmware.vise.util.logging.LogServiceImpl                       [Flex|AppErrorHandler]Error #1009

TypeError: Error #1009

0 Kudos
charite
Contributor
Contributor

We have also the problem. Is there any solution?!

Thanks!

0 Kudos
mdac
Enthusiast
Enthusiast

This is a known problem in 6.3.6 and 6.4.1, unfortunately. KB 56389 discusses this:

VMware KB 56389

If any certificates have <certificateType> being NULL, this hang occurs. The KB discusses a workaround that can be done via REST API.

Hope this helps.

My blog: https://vswitchzero.com Follow me on Twitter: @vswitchzero

View solution in original post

charite
Contributor
Contributor

Thank you! This worked for us. Smiley Happy
I searched in the Knowledge Base for this behavior and didn´t find this KB.

MillardJK
Enthusiast
Enthusiast

That was it; found 2 certs with no type. After removing them, the manager started working again.

——
Jim Millard
Kansas City, MO USA