Enthusiast
Enthusiast

Unable to prepare compute cluster in homelab

Hi all,

I'm installing NSX 6.3 in a nested ESXi 6.5/VCSA 6.5 environment. When I previously did this I had an issue preparing my compute cluster, documented here : https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=20537...

Also covered in another blog post here : http://www.sneaku.com/2015/08/27/nsx-v-unable-to-install-vibs-blame-vum/

However, I performed the same tasks as I did on a previous version of my lab (going to https://vc/eam/mob/, selecting my agent, selecting update and supplying:

<config>

          <bypassVumEnabled>true</bypassVumEnabled>

</config>

I get "Method Invocation Result: void" after invoking this method, which implies that it's processed that update, however when I check the config again it states:

bypassVumEnabled boolean false

Has anyone come across this issue before?

Thanks

0 Kudos
8 Replies
Enthusiast
Enthusiast

Dear,

My advice is not to use nested ESXi 6.5/VCSA 6.5 environment. I have also tried many times to configure NSX on nested environment but always face a new error. Please configure the NSX on bare metal. I have one server with 64 GB RAM. I have installed esxi 6.5 on it and add this single host on the cluster and successfully configured NSX. Through this lab i have configured all the components like edge, DLR, Firewall, DHCP, DNAT,SANT, Static and Dynamic Routing, Load Balancing.

0 Kudos

I ran into the same issue. Have you solved the problem?

https://mycloudrevolution.com | https://twitter.com/vMarkus_K | https://github.com/vMarkusK
0 Kudos
Leadership
Leadership

Do you see any error in the eam.log that points to the VUM issue?

When I had a host preparation issue related to VUM, what I saw on the eam log was:

“com.vmware.vim.vmomi.client.exception.ConnectionException: org.apache.http.conn.HttpHostConnectException: Connection to https://<vCenter_Server_Hostname>:8084 refused”

and 8084 is the port number for VUM

See if restarting EAM as per below blog post fix the issue:

NSX Host preparation failure. Restart EAM – vLenzker

Bayu Wibowo | VCIX6-DCV/NV Author of VMware NSX Cookbook http://bit.ly/NSXCookbook https://github.com/bayupw/PowerNSX-Scripts https://nz.linkedin.com/in/bayupw | twitter @bayupw
0 Kudos

Service restart has not solved the Bypass issue.

But I have fixed my root cause (the reason why I wanted to enable Bypass ) .

https://mycloudrevolution.com | https://twitter.com/vMarkus_K | https://github.com/vMarkusK
0 Kudos
Leadership
Leadership

Could you share what was the fix to your issue?

Bayu Wibowo | VCIX6-DCV/NV Author of VMware NSX Cookbook http://bit.ly/NSXCookbook https://github.com/bayupw/PowerNSX-Scripts https://nz.linkedin.com/in/bayupw | twitter @bayupw
0 Kudos

I have solved the Failed Agent Installation process, not the problem with the eam Bypass.

In my case outgoing https traffic on ESXi host was blocked.

https://mycloudrevolution.com | https://twitter.com/vMarkus_K | https://github.com/vMarkusK
0 Kudos
Enthusiast
Enthusiast

Markus can you be more specific? By what exactly your https traffic was blocked? For me i have enabled httpClient via Security Profile but didnt help.

0 Kudos

Traffic was blocked by ESXi internal Firewall.

https://mycloudrevolution.com | https://twitter.com/vMarkus_K | https://github.com/vMarkusK
0 Kudos