pras23ps
Contributor
Contributor

Not able to add the removed NSX-T Local Manager back to Global Manager

Jump to solution

Hi Team,

For some reason i had to remove the local manager(LM) from global which i did by following the pre-requisites i.e. global manager(GM) realted configuration done on LM were removed manually and then LM was removed from GM succesfully.

The issue what i am facing is that when i am trying to add LM back to GM, I am geting error "Error: Site <site-name> offboarding is not completed. (Error code: 530028)  further to troubleshoot i see on LM the default segment profile and default VPN profiles still listed of GM. I have restarted the LM controllers to see if it helps,however no luck.Need to know how can we fix it. Screen shot attached for reference. Thanks 

1 Solution

Accepted Solutions
chandrakm
VMware Employee
VMware Employee

Check the off-boarding status on LM:

GET https://<LM>/policy/api/v1/infra/site/offboarding-status

 

once you found dependent object holding the cleanup. try to force DELETE it through API call

Example - DELETE https://<LM>/policy/api/v1/global-infra/<ComponentPath>?override=true

 

You can try below too in conjunction with above:

Reset SiteManager on LM
POST https://<LM>/api/v1/sites?action=reset


Cleanup config from LM (there is a small typo in the original API you uses 'sites' -> 'site')
POST https://<LM>/policy/api/v1/infra/site?action=offboard

 

Let me know if this helps!

View solution in original post

2 Replies
chandrakm
VMware Employee
VMware Employee

Check the off-boarding status on LM:

GET https://<LM>/policy/api/v1/infra/site/offboarding-status

 

once you found dependent object holding the cleanup. try to force DELETE it through API call

Example - DELETE https://<LM>/policy/api/v1/global-infra/<ComponentPath>?override=true

 

You can try below too in conjunction with above:

Reset SiteManager on LM
POST https://<LM>/api/v1/sites?action=reset


Cleanup config from LM (there is a small typo in the original API you uses 'sites' -> 'site')
POST https://<LM>/policy/api/v1/infra/site?action=offboard

 

Let me know if this helps!

chandrakm
VMware Employee
VMware Employee

@pras23ps did this helped in solving the problem? If yes mark as solved or post further updates

0 Kudos