ayadav40
Contributor
Contributor

NSX home Lab internal logical switch vm not able to ping google.

Jump to solution

Hi All,

I have one physical host on which i have installed ESXi 6.5, that have 2 physical NIC's and all nested servers are on single NIC which is connected to simple switch which have connectivity to ISP router.

I have built NSX nested lab and able to connect all logical switch vm with each other through DLR and also upto Edge uplink interface but when i am trying to ping google or any other ip address its not pinging.

Need help, is there any NAT is required or any other setting.

0 Kudos
1 Solution

Accepted Solutions
p0wertje
Hot Shot
Hot Shot

Hi,

A route is normally not enough for natting. Depening on your router brand you most likely need to enable nat somewhere.
You only route 10.1.0.0/24 now. But you have subnets in 10.1.10.0/24. Better to user 10.1.0.0/16

Cheers,
p0wertje | VCIX6-NV | JNCIS-ENT
Please kudo helpful posts and mark the thread as solved if solved

View solution in original post

0 Kudos
6 Replies
p0wertje
Hot Shot
Hot Shot

Hi,

- Can you ping google from the edge gateway ?

- Where do you normaly do natting ? on the isp router ? When this is a home lab, i assume you have a dsl/cable provider being the 'isp-router'

Assuming isp being cable/dls

- you need to add 10.1.x.x to the natting on the isp router.

- you need to add a route on the isp router for 10.1.x.x with the next hop being the edge

OR

- you need to add 10.1.x.x to the edge with natting.

- then you do not need aditional routing.

Cheers,
p0wertje | VCIX6-NV | JNCIS-ENT
Please kudo helpful posts and mark the thread as solved if solved
0 Kudos
ayadav40
Contributor
Contributor

Hi Chris,

Thanks for the reply, attach is the route from my DLR/EDGE. I am able to ping google from edge gateway but not from DLR below are the route that i added on my ADSL modem.

Destination ip       Mask                 Gateway             Metric    device       use

10.1.0.0                 24                 192.168.1.240         2            enet0       0

Still i am not able to ping google from logical switch vm's, I don't have much knowledge about routing can you please suggest.

Thanks,

Anuj

0 Kudos
p0wertje
Hot Shot
Hot Shot

Did you add natting for 10.1.x.x  ?

Or on you dsl modem

Or on the edge ?

You need to have it in one of those places.

Cheers,
p0wertje | VCIX6-NV | JNCIS-ENT
Please kudo helpful posts and mark the thread as solved if solved
0 Kudos
ayadav40
Contributor
Contributor

Yes i have done on DSL router as

Destination ip       Mask                 Gateway             Metric    device       use

10.1.0.0                 24                 192.168.1.240         2            enet0       0

please let me know if its correct for need to make any changes.

0 Kudos
p0wertje
Hot Shot
Hot Shot

Hi,

A route is normally not enough for natting. Depening on your router brand you most likely need to enable nat somewhere.
You only route 10.1.0.0/24 now. But you have subnets in 10.1.10.0/24. Better to user 10.1.0.0/16

Cheers,
p0wertje | VCIX6-NV | JNCIS-ENT
Please kudo helpful posts and mark the thread as solved if solved

View solution in original post

0 Kudos
ayadav40
Contributor
Contributor

Wonderful Chris, it worked and i am able to ping 8.8.8.8 from my logical switch vm's, thanks for the help..!!!

I have changed mask from 24 to 16 and it worked on my ADSL modem/router.

Thanks,

Anuj

0 Kudos