wizkid686
Contributor
Contributor

NSX-V 6.4.5 Not Ready but VIBs Installed on vSphere 6.7

Hi,

We're in the process of deploying a new installation of NSX-V 6.4.5 on vSphere 6.7 Update 2c.

We have gotten NSX linked with vCenter and successfully deployed the controller cluster, but have run into an issue when we try to prepare the cluster for NSX.

The VIBs get installed on our compute hosts and report green, but NSX still says Not Ready. We've already tried rebooting our compute hosts, vCenter, and NSX, and tried uninstalling and reinstalling the prepare cluster steps, but we are still encountering this issue.

Any help would be greatly appreciated. We run VCSA (not windows vCenter) with an embedded PSC.

0 Kudos
10 Replies
lmoglie
Enthusiast
Enthusiast

Hi Benjamin,

forgive me, but is not clear to me where the message "Not Ready" appears. Can you please provide us a screenshot??

Regards

LM

0 Kudos
singho
VMware Employee
VMware Employee

Can you try this.

VMware Knowledge Base

0 Kudos
wizkid686
Contributor
Contributor

lmoglie

Here is a screenshot with the issue we are having:

pastedImage_2.png@

0 Kudos
wizkid686
Contributor
Contributor

singho

While this does describe the issue we are having, the resolutions are not applicable to us. We do not use a proxy on VUM/vCenter in our environment, and we use the vCenter Server Appliance, not Windows vCenter.

0 Kudos
mauricioamorim
VMware Employee
VMware Employee

There is usually an option to click resolve? Does it show in more actions or under the flash UI?

0 Kudos
wizkid686
Contributor
Contributor

I have already tried the resolve option and it does not correct this issue, it still shows the same screen shown previously.

0 Kudos
mauricioamorim
VMware Employee
VMware Employee

Both vCenter and Esxi are on 6.7 Update 2c?

Did you check the proxy configuration on the kb that was sent?

0 Kudos
wizkid686
Contributor
Contributor

vCenter is 6.7 Update 2c, ESXi is either Update 2 or Update 3 (I don't recall if the latest set of ESXi patches which would have pushed it up to 6.7 Update 3 were applied yet). We're not able to upgrade vCenter from Update 2c to Update 3 right now (the CLI software-packages command says everything is already up-to-date when we try to stage 6.7 Update 3).

I already reviewed the KB article, we do not use a proxy in our environment, and one was not set in the VUM config or vCenter's config.

0 Kudos
lmoglie
Enthusiast
Enthusiast

HI Benjamin,

have you seen this (https://www.sneaku.com/2015/08/27/nsx-v-unable-to-install-vibs-blame-vum/ )

Even if you don't use VUM, and VIB seems to be correctly installed be sure that :

<config>

   <bypassVumEnabled>false</bypassVumEnabled>

</config>

And also be sure that all ports between ESXi, vCenter (/PSC) and NSX Manager are correctly open.

In the past i solved it by doing so.

Regards

LM

0 Kudos
wizkid686
Contributor
Contributor

I have tried setting bypassVumEnabled to true per another VMware KB article and the setup instructions for NSX-V. However, the change will not stick. After I set the config in the MOB and get the method invocation result: void response indicating it was successful, another check of the agency config in MOB indicates the settings has flipped back to false.

As for firewall settings, I've checked the ESXi hosts and they show that all the ports required for NSX to work are open. Since all of our VMware stuff sits on the same network, there's not any other firewall that would be blocking those ports.

0 Kudos