Highlighted
Contributor
Contributor

NSX-T BGP Realization errors: XXXX-XXXX "There are some unknown runtime issues." after creating a BGP neighbor

Hello,

I'm deploying 4 x NSX-T Edge cluster VMs over  2xESXi Edge hosts. Each Edge VM has its own T0 running BGP with external PE routers.

NSX-T Version 2.5.1.0.0.15314288

When defining new BGP peers they stay UP (green) for 30 seconds aprox, and then come down.  The following error is returned:  Realization Errors : 1c186f60-6f7d-11ea-8617-f19d74c060ac There are some unknown runtime issues.

There is a similar discussion titled Solved: NSX-T BGP neighbor down "There are some unknown runtime issues." in this forum. The solution provided there, as far as I understand, was to disconnect the ESxi host uplinks to the routers. I cannot try this because I'm working with Edges VM, not bare metal Edges as it seems to be the case in that thread.

The following snapshot self describes the problem:

pastedImage_4.png

I attempted the following actions before writing this thread without any progress:

1) recreate the BGP neighbors (several times)

2) recreate the T0 + BGP neighbors

3) recreate the transport zones+ both Edge VMs `+ T0 + BGP neighbors

4) Reboot  the NSX-T Manager and both ESXi Edge hosts.

Curiously, the previoulsy created BGP peers of other T0's in other Edge VMs are working fine. But If I delete one of these working BGP peers and try to recreate it, fails exactly with the same symptom. So it does not seem to be a problem related to an especifical edge, but a more internal problem.

Regards in advance.

Realization Errors : 1c186f60-6f7d-11ea-8617-f19d74c060ac

  • There are some unknown runtime issues.
0 Kudos
3 Replies
Highlighted
Contributor
Contributor

Curious if you ever solved this.. I'm having the same issue.

0 Kudos
Highlighted
Enthusiast
Enthusiast

Out of curiosity, have you checked in the CLI? Meaning have you checked the BGP neighbours as sometimes this can just be a GUI issue.  I have seen this several times, however peering was successful.

Shashank Mohan

VCAP-NV 2020 | VCP-DCV2019 | CCNP Specialist

https://lab2prod.com.au
0 Kudos
Highlighted
Contributor
Contributor

I did, and peering was not successful. However, I deleted the bgp neighbors, the T0 interface, and the segment that was used for the external interface (for the 4th or 5th time...) and reconfigured it all the exact same way (... for the 4th or 5th time) and it magically worked..

Oddly, I've had similar issues with other things in NSX, where I'll make a change that doesn't seem to work, delete and reconfigure all the components related to said change, and it works..

0 Kudos