Highlighted
Hot Shot
Hot Shot

NSX-T 3.0 - upgrade UI blank

I want to do an upgrade to 3.1

When selecting the Upgrade option in the UI, I get a blank screen:

Czernobog_0-1605794726966.png

Tried different browsers, relogging, restarting the ui service.

Any idea what can cause this?

edit:

all other UI elements are displayed witohut issues.

edit2:

I currently only have one NSX Manager node. Had more before, due to a hardware migration the cluster was reduced to one node.

The upgrade service is running:

Service name: install-upgrade
Service state: running
Enabled on: [ip of the mgr node]

Tags (1)
0 Kudos
3 Replies
Highlighted
Commander
Commander

Hey @Czernobog,

Have you tried to login by using different accounts and to point not only to the FQDN but also to the IP?

0 Kudos
Highlighted
Hot Shot
Hot Shot

I have tried it with my LDAP-bound account (Enterprise Admin role) and also the default admin.

Tried logging into the applaince by FQDN and IP, also tried to delete all cluster nodes except one, whiel also removing the cluster VIP.

Edit: one of the manager nodes cannot sync the repository. Also the removal of a manager node the past, and the resulting leftover information might be the cause of upgrades not working.

0 Kudos
Highlighted
Commander
Commander

Hey @Czernobog,

Definetely the issue is because of the sync not working properly. I thought you said that you only had one node. Try to re-deploy the faulty one if it cannot sync.

Also make sure to get the information of which node has the upgrade service running.

0 Kudos