nagesh_u
Enthusiast
Enthusiast

Migration from NSXV to NSXT

Jump to solution

Hi Team,

trying to migrate from the NSX-V to NSX-T but got below error, not sure why ?

 

Config migration failed [Reason: HTTP Error: 400: Found errors in the request. Please refer to the related Errors for details. for url: #http://localhost:6440/policy/api/v1/infra/tier-0s/None/locale-services/default/ipsec-vpn-services/ed...

 
 
Transport ZoneTransport ZoneL24/4
 
Enforcement PointEnforcement PointL21/1
 
MAC ManagementMAC Discovery ProfileSwitching Profiles1/1
 
Traffic Shaping PolicyQOS ProfileSwitching Profiles1/1
 
Security ProfileSegment Security ProfileSwitching Profiles1/1
 
Spoof Guard ConfigurationSpoof Guard ProfileSwitching Profiles1/1
 
IP DiscoveryIP Discovery ProfileSwitching Profiles2/2
 
Virtual WireSegment PathL25/5
 
Switching ProfilesDiscovery Profile Binding MapsL211/11
 
Switching ProfilesSecurity Profile Binding MapsL211/11
 
Switching ProfilesQOS Profile Binding MapsL211/11
 
DV Port GroupsSegment PathL28/8
 
DV SwitchUplink Host Switch ProfileHost Switch2/2
 
DV SwitchUplink Host Switch Profile VXLANHost Switch1/1
 
Edge InterfaceEdge InterfaceEdge3/3
 
DV SwitchUplink Host Switch ProfileEdge1/1
 
Edge NodeEdge Transport NodeEdge3/3
 
Default EdgeEdge ClusterEdge1/1
 
Enforcement PointEnforcement PointEdge1/1
 
IPAM Address PoolIP PoolHost2/2
 
IPAM Address Pool SubnetIP Pool SubnetHost2/2
 
EdgesProvidersEdge1/1
 
EdgesProvider LocaleEdge1/1
 
Policy Edge PathPolicy Edge PathEdge3/3
 
Edge InterfaceTier0 InterfaceEdge3/3
 
Downlink Segment PathDownlink Segment PathEdge1/1
 
staticRouteStaticRouteEdge6/6
 
Appliance CertificateCertificateApplianceMangement1/1
 
MAC SetGroupGrouping Objects1/1
 
Security GroupGroupGrouping Objects1/1
 
ApplicationContext ProfileNS Service130/130
 
ApplicationServiceNS Service158/158
 
Application GroupServiceNS Service29/29
 
DFWDFWDistributed Firewall1/1
 
DFW Default RuleDFWDistributed Firewall1/1
 
DFW SectionDFW SectionDistributed Firewall2/2
 
Firewall CPU Memory Thresholds ProfileFirewall CPU Memory Thresholds ProfileDistributed Firewall1/1
 
Security GroupSecurity GroupDistributed Firewall1/1
 
CPU Memory Threshold ProfileService ConfigDistributed Firewall1/1
 
EdgeIpsecVpnServiceEdge0/2
 
EdgeTunnelProfileEdge0/2
 
EdgeIkeProfileEdge0/4
 
EdgeLocalEndpointEdge0/2
 
L3VPN siteL3VPNEdge0/2
 
dhcp-relaydhcp-relay-configEdge0/3
 
0 Kudos
1 Solution

Accepted Solutions
nagesh_u
Enthusiast
Enthusiast

Hi Shashank,

Thank you so much for the help , i have resolved the issue.

i have configured IPsec VPN tunnel on nsxv and i have disabled as NSXT migration will not support but i did not remove the configuration so i was getting error. i have removed the IPsec VPN tunnel in both my nsxv edge and then rerun the migration all successfully migrated.

all UP and running now

View solution in original post

0 Kudos
9 Replies
shank89
Expert
Expert

Can you please describe the environment a little more, what sort of migration you are doing and at what point it has / is failing?  Have you done the pre-migration assessment?  What was the outcome of that?

Shashank Mohan

VCAP-NV 2020 | VCP-DCV2019 | CCNP Specialist

https://lab2prod.com.au
0 Kudos
nagesh_u
Enthusiast
Enthusiast

i am doing NSX-V to NSX-T migration and al pre-req is looks good:

please find the screen shot:

 

nagesh_u_0-1614997620162.png

 

nagesh_u_1-1614997643424.png

 

but its failing 91%

nagesh_u_2-1614997889895.png

 

nagesh_u_3-1614997907067.png

 

pending task:

 

nagesh_u_4-1614997932286.png

 

Tags (1)
0 Kudos
a_p_
Leadership
Leadership

Moderator: Moved to VMware NSX Discussions

0 Kudos
shank89
Expert
Expert

Ok, can you tell me a little about your T environment?  The URI it is trying to hit, looks as though there are no edges deployed?

Shashank Mohan

VCAP-NV 2020 | VCP-DCV2019 | CCNP Specialist

https://lab2prod.com.au
0 Kudos
nagesh_u
Enthusiast
Enthusiast

i have installed EDGE in NSX T, i did not configured the nsx-t edge as per below video and   while migrating nsx-t edge configured, if i roll back that will remove the edge configured and i dont have option to resume 

https://www.youtube.com/watch?v=RRvTk4T4FBU&t=272s

nagesh_u_0-1615134427477.png

below is the my NSX -V Edge:

 

nagesh_u_1-1615134875257.png

 

0 Kudos
nagesh_u
Enthusiast
Enthusiast

i am not sure what service need to run to fix it  

 

Config migration failed [Reason: HTTP Error: 400: Found errors in the request. Please refer to the related Errors for details. for url: http://localhost:6440/policy/api/v1/infra/tier-0s/None/locale-services/default/ipsec-vpn-services/edge-8-ipsecVpnService]

0 Kudos
shank89
Expert
Expert

Have any T0 gateways been created / configured?

Shashank Mohan

VCAP-NV 2020 | VCP-DCV2019 | CCNP Specialist

https://lab2prod.com.au
0 Kudos
nagesh_u
Enthusiast
Enthusiast

Hi Shashank,

Thank you so much for the help , i have resolved the issue.

i have configured IPsec VPN tunnel on nsxv and i have disabled as NSXT migration will not support but i did not remove the configuration so i was getting error. i have removed the IPsec VPN tunnel in both my nsxv edge and then rerun the migration all successfully migrated.

all UP and running now

View solution in original post

0 Kudos
shank89
Expert
Expert

Ah good catch, glad you worked it out!

Shashank Mohan

VCAP-NV 2020 | VCP-DCV2019 | CCNP Specialist

https://lab2prod.com.au
0 Kudos