RussH
Enthusiast
Enthusiast

LDR Edge not communicating with host

Jump to solution

Hi,

I'm using NSX-V 6.1 and vSphere 5.5

In my lab I have a problem where a LDR Edge is not communicating with the host (and not populating the LDR routing table on the host - confirmed with net-vdr -I -l).

tail'ing the netcpa.log while the LDR starts produces the following output (repeating every couple seconds )

2014-09-29T09:50:53.784Z [FFE26B70 error 'Default'] VSE authToken 28d04be3-39c2-4907-a38c-321a040418ed unknown

2014-09-29T09:50:53.784Z [FFE26B70 error 'Default'] vmci authentication failed, closing fd 11

I've rebuilt the lab twice but the same issue occurs.

Anyone experienced anything similar?

thanks

1 Solution

Accepted Solutions
SpasKaloferov
VMware Employee
VMware Employee

After that do an SSH to the host and run /etc/init.d/netcpad restart

This should populate your VDR info again.

Best Regards / Поздрави

Spas Kaloferov | Technical Solutions Architect

View solution in original post

10 Replies
SpasKaloferov
VMware Employee
VMware Employee

Hi same issue here,

disconnect and reconnect the host fixes it for me.

0 Kudos
RussH
Enthusiast
Enthusiast

Hi... Thanks for the hint.  When you say disconnect/reconnect....where abouts are you doing this?

Thanks

0 Kudos
SpasKaloferov
VMware Employee
VMware Employee

HI,

- Logon to vCenter , nagivate to the host , right click and select Disconnect. After that right click agian and select Connect.


Best Regards / Поздрави

Spas Kaloferov | Technical Solutions Architect

0 Kudos
SpasKaloferov
VMware Employee
VMware Employee

After that do an SSH to the host and run /etc/init.d/netcpad restart

This should populate your VDR info again.

Best Regards / Поздрави

Spas Kaloferov | Technical Solutions Architect

View solution in original post

RussH
Enthusiast
Enthusiast

Thanks a lot.... Will try it out later

0 Kudos
RussH
Enthusiast
Enthusiast

Tried this out this morning. The /etc/init.d/netcpa restart did work although it took a few service restarts (3 or 4) before the error went away.

Thanks a lot for the tip!

0 Kudos
rbudavari
VMware Employee
VMware Employee

For a simpler approach (particularly across multiple hosts in a cluster for larger environments) the recommended option is to navigate to Installation -> Host Preparation then under Installation Status click on the version number and select 'Force-Sync Routing services'

Screenshot below:

force-sync.png

Also there is no need to disconnect/reconnect the ESXi hosts.

SpasKaloferov
VMware Employee
VMware Employee

HI,

for this particular issue this is no the case. 'Force-Sync Routing services' is not going to help, I think it is the same issue/case as i described here:

NSX VXLAN Enable Agent fails on ESXi hosts with error “Cannot complete the operation.”

http://kaloferov.com/blog/nsx-vxlan-enable-agent-fails-on-esxi-hosts-with-error-cannot-complete-the-...

0 Kudos
SpasKaloferov
VMware Employee
VMware Employee

Mostly you don't have to disconnected/reconnect. Just make sure the NSX manager is up and running and run the commands form the article.

0 Kudos
rbudavari
VMware Employee
VMware Employee

No - they do the same thing Smiley Happy

0 Kudos