VMware Networking Community

ESXi host PSOD after upgrading from vShield to NSX

Hi all,

I have just upgraded my environment from vCNS 5.5 to NSX 6.2.4 for vShield Endpoint. I am currently using only the Guest Introspection service for integration with a 3rd party agentless anti-malware software (trendmicro deep security). Following the official procedure,the upgrade process has been completed with no particular issue and after the deploy of the agent VMs (Guest Introspection and trend micro appliance) the anti-malware service is working fine on the Guest VM (it is a VDI environment with windows7 VM based on horizon 6.2.1).

The problem is that I am experiencing random PSOD errors on most of the hosts being part of my VDI cluster. I have also applied the configuration required to block vmotion of the agent VMs (according this KB: Migration of Service VM (SVM) may cause ESXi host issues in VMware NSX for vSphere 6.x (2141410) | V... ) but the problem persists.

Please share your advice on this issue.

Thank you very much!

2 Replies
VMware Employee
VMware Employee

Not every PSOD can be easily confirmed by looking at the purple screen. If you have logs available prior to PSOD that would be very helpful. As of now, we cannot confirm if it is hardware/software issue. But you should a general health test (Hardware diagnostic test on one of the server),confirm BIOS,drivers etc etc are updated. If we really need to isolate "it has something to do with Agent VM, Guest Introspection service" - if feasible you can remove the component from one server and migrate VM from that server and run some test machines and monitor. Quickest way to resolve would be log a SR with VMware. But i will always do a general hardware check before opening a SR.

Sree | VCIX-5X| VCAP-5X| VExpert 6x|Cisco Certified Specialist
Please KUDO helpful posts and mark the thread as solved if answered

Thanks for your answer.

The issue has been solved with the installation of the ESXi 6.0 U2 Patch 4.


PSOD occurs due to race condition in dvfilter vmci socket deregistration. A small window existed in which function pointers are NULLed out but we haven't actually deregistered the socket callback.


This issue is resolved in ESXi 6.0 P03 . If you have VMware NSX 6.2.2 version running do not upgrade to ESXi 6.0 P03 but upgrade to a later version of patch. Refer to KB - vsfwd connection to the NSX Manager fails -- https://kb.vmware.com/kb/2146873