owiegmann
Enthusiast
Enthusiast

Can"t login to NSX-T 2.4 Manager UI after deployment

Jump to solution

When I try to login I get the following information:

{

  "module_name" : "common-services",

  "error_message" : "Some of appliance components is not functioning.",

  "details" : "Component health: MANAGER:UNKNOWN, POLICY:UP, SEARCH:UP, UI:UP",

  "error_code" : "101"

}

Try to find something helpful in the log files but where I get the right information?

Tags (1)
1 Solution

Accepted Solutions
daphnissov
Immortal
Immortal

If you're getting that immediately after deploying the Manager, either you've provided some bad inputs, aren't waiting long enough for it to come up, or the appliance is corrupt in some way. Redeploy to try again.

View solution in original post

0 Kudos
5 Replies
daphnissov
Immortal
Immortal

If you're getting that immediately after deploying the Manager, either you've provided some bad inputs, aren't waiting long enough for it to come up, or the appliance is corrupt in some way. Redeploy to try again.

0 Kudos
owiegmann
Enthusiast
Enthusiast

You are right. Today I could login and start with the configuration. It takes a long time to bring all the services up, 60-90 minutes I guess.

0 Kudos
Harish_Chilikot
Enthusiast
Enthusiast

60-90 minutes seems too long to bring all the services. Typically the time taken to bring up all the services could be due to there is a resource contention(cpu/mem). Can you check if this is the case.

ramns
Contributor
Contributor

NSX-T 2.4 had been up and running for almost two months. We see the error message almost every week. When I reboot the nsx-t manager, this error message goes away and am able to access the nsx-t manager. But this time, its stuck at this error message no matter. There is no access to the UI. All service are up on the nsx-t as well as three nodes. The get nodes returns nothing at all.

> get nodes

UUID                                   Type  Display Name

>

#its been behaving like this, the whole weekend

>get cluster status

% The get cluster status operation cannot be processed currently, please try again later

>

> get node

UUID                                   Type  Display Name

>

How do I get the nsx-t 2.4 cluster to converge ?

0 Kudos
mauricioamorim
VMware Employee
VMware Employee

From what I have seen seems like resource contention. When controllers are at very high CPU I have seen that get cluster status doesn't return anything and UI access also doesn't work. This is usually temporary. Might be good to give more resources to the NSX-T Managers and also reserve the CPU resources.

0 Kudos