nluchetta
Contributor
Contributor

vmware integrated openstack Failed to execute task: Inner

Hello

I am attempting to bring up a new VIO environment and have run into an issue early on. After clicking "deploy Openstack" and providing configuration information about 80% though the install an error presents.

openstack error 2.JPG

When I look at all of my machines they are turned on but say "bootstrap failed"

I have the prerequisites for openstack met (at least I think I do). During deployment I selected ignore SSL Certificate so that should not be in play.

Any insights would be appreciated.

Thanks.

0 Kudos
6 Replies
admin
Immortal
Immortal

What version of VIO are you using? And what authentication backend are you using, local db or AD?

0 Kudos
nluchetta
Contributor
Contributor

Thanks for the response.

Version: 2.0.3

Build: 3717954

Openstack: 2015.1.1

I am using local DB authentication.

0 Kudos
ssurana
VMware Employee
VMware Employee

Could you provide the following log files:

/var/log/oms/oms.log

/var/log/jarvis/jarvis.log

/var/log/jarvis/ansible.log

0 Kudos
Stephane_Grandg
Enthusiast
Enthusiast

after providing the logs required by

can you log to oms and  run the following command :

sudo viocli deployment resume

and post the error you get ?

0 Kudos
djmoose
Contributor
Contributor

I had the same problem. For me it was because I wasn't entering the FQDN for the NSX manager at the deployment settings: (see attachment)

It's hard to catch because if your workstation can resolve the name, it connects to the NSX manager and pulls in all the needed information for the next couple of fields.

However, during the install, the nsx hostname you enter here gets passed into a script...and if the vio manager can't resolve fully, it can't connect to the NSX manager.

0 Kudos
Raducanu
Enthusiast
Enthusiast

May you can check /var/log/jarvis/ansible.log on you management appliance?

There you should find the first hint

0 Kudos