vm_turtle
Contributor
Contributor

VIO Icon is not showing up in the vSphere Web Client, Possible networking issue

Good morning all. I am currently attempting to set up Openstack on top of VMware using VIO. I have been following the instructions here:

https://pubs.vmware.com/integrated-openstack-1/topic/com.vmware.ICbase/PDF/integrated-openstack-10-g...(VDS deployment).

Everything was going fine until I launched the vApp for VIO. The icon never showed up. The management vm that is powered on says "NO NETWORKING DETECTED". I have no idea what the problem is or if these two issues are even related. I followed all the instructions, including placing all of my hosts on the same VDS. Any hints as to what went wrong?

Tags (3)
0 Kudos
7 Replies
yjia
VMware Employee
VMware Employee

Hi

1>Please make sure you input a valid IP address and DNS for the management server when you deploy the ova, Generally Management server will require a static IP.

2> Please check if your can login to the Management server, if yes, then please run the follow command "viogetlogs"  and please upload the result.

Regards,

Yixing.

0 Kudos
vm_turtle
Contributor
Contributor

Ok, I corrected the ip and now the icon is appearing. However, I an unable to connect to the management server. I get an error that says "Please check whether the SSO has been enabled from the OpenStack management server log at:/installer.log.".

0 Kudos
yjia
VMware Employee
VMware Employee

Hi, If your run VC5.5

Then please do the follow on Management server.

$>enablesso https://vcip[or VCFQDN]:7444/sdk/lookupservice

Then restart the OMS server

$> restart oms

If this still not work, Please run

$> viogetlogs

and send me the result.

Regards,

Yixing.

0 Kudos
john23
Commander
Commander

I am facing same problem, VIO icon is coming but not able to connect from web clinet.

I am using vsphere 6.0 and running following command

enablesso https://<ip>/lookupservice/sdk  (have tried with and without 7444 port

Error message server certificate assertion not verified and thumbprint not matched.

I tried insecure option as well and its not working///

Thanks -A Read my blogs: www.openwriteup.com
0 Kudos
vm_turtle
Contributor
Contributor

Well, I tried logging out of the vSphere web client, then I ssh'ed into the vCenter Server and restarted the vCenter service. Then I logged back in to the web client and it showed up and worked. Not sure if that will help at all.

0 Kudos
JunW
Enthusiast
Enthusiast

Hi John,

For VC 6.0, in most cases, if your sso server is embedded into the VC server, the sso sever url will be: https://VC_FQDN/lookupservice/sdk . Otherwise, please put https://sso_server_FQDN_or_ip/lookupservice/sdk there.

Please do the following steps on Management server as root account to update the correct sso server url:

$>enablesso https://VC_FQDN/lookupservice/sdk

Then restart the OMS server

$> service oms restart

That should work.

Thanks,

Jun

0 Kudos
JunW
Enthusiast
Enthusiast

A tip for SSO lookup service url is: if your sso server is embedded into vc server, you just left the default url there unchanged during OVA deployment, and the management server will find the correct sso lookupservice url automatically if VC is configured correctly.

0 Kudos