ziggyziggy
Contributor
Contributor

VIO 3.0 Compact mode VDS deployment Error

Hi,

During the process of Deploy VIO 3.0 in Compact mode VDS, on the (2nd) screen where I should "Enter the administrator credentials for the vCenter Server." I type the hostname of the existing vCentre and SSO credentials for administrator of the domain. After trying the step 3 Select the management cluster, during the init of this form, it fails with the Error #1009. I tried to clear this error following instruction at The VMware vSphere Web Client reports an internal error 1009 (2089949) | VMware KB but this did not help.

The error suggest reloading the vSphere client, if I ignore that, in the following table, I don't see any clusters listed, and I can't select management cluster...

Looking at the oms logs (/var/log/oms/oms.logs) I see that the authentication to SSO service is (should be) successful:

...

[2017-05-05T08:52:01.207+0000] INFO  tomcat-http--27| com.vmware.openstack.vc.AuthenticateVcUser: Try update vc service: https://10.151.65.132:443/sdk

[2017-05-05T08:52:01.270+0000] INFO  tomcat-http--27| com.vmware.openstack.vc.AuthenticateVcUser: VSPHERE-SSO.<DOMAINED_HIDDEN>\Administrator is authenticated

...

For the context, vCentre is deployed as Appliance in the same management cluster as VIO. There is a separate empty compute cluster with one ESXi host.

Where should I look for more debugging information and what would be the best way to locate the root cause of this?

From the documentation it is unclear to me should I select Use management vCenter Server as Compute vCenter Server , when deplying in VDS mode?

Documentation stated to "Select this option to deploy on multiple vCenter servers. This option is supported on NSX deployments only.", but screen in the VIO Deployer states the opposite -- only supports NSX when management and computer clusters are deployed to separate vCenter Servers... ?

I'm constrained on HW resources for the lab, so I can't deploy in HA mode, nor support NSX.

Versions used:

vCenter Server 6.50 Build 4944578

VIO 3.0.0 Build 4345506

ESXi, 6.0.0, 4192238

HP ProLiant DL380p Gen8

Best regards,

0 Kudos
1 Reply
Grimsrud
VMware Employee
VMware Employee

VIO 3.0 is not compatible with vCenter 6.5, either use VIO 3.1 or downgrade vCenter to 6.0u2

You can check interoperability at VMware Product Interoperability Matrices

Regards

Christian

0 Kudos