iulianco
Contributor
Contributor

Multiple input devices (trackballs or mouse devices)

I'm using VSphere 7 and Horizon 8, on some of the guest Windows 10 VMs, I plan to use dual trackballs or mouse devices from a client Horizon machine, have written software that handles them such that you can use both at the same time and have independent "cursor" or input capability and that's fine on a physical machine.

Using VMs though, I don't seem to have distinct mice/trackball devices as such, both work but appear as a single device, I think it might be "VMware USB Pointing Device" (there is also a PS/2 VMware Pointing Device but I don't think that's used in our case).

Is there a way I could reconfigure the VM such that I see both devices inside Device Manager? Have looked it up and found some mention to add to the .vmx file an option usb.generic.allowHID = "TRUE", have added it with VCenter to the VM in question, but doesn't seem to have had the desired effect.

Thank you in advance.

0 Kudos
2 Replies
iulianco
Contributor
Contributor

So in the end I managed to find a solution to my own problem.

It turns out, by default, keyboards and mouse devices are not forwarded to the virtual machine as individual devices by the Horizon Client (at least the version I am using Horizon 8 - 2206). The setting in question is a USB policy setting for the Horizon Agent (that's right, the Agent policy - to one on the VM side,  not the Client, but this is one of the policies that the Horizon Client downloads from the Agent and then uses it in addition to its own settings to decide how to redirect USB devices).

To enable this, you need to download and copy the administrative templates (the files with the extension .admx) to the Windows VM (Agent side) in the Windows\PolicyDefinitions directory (e.g. C:\Windows\PolicyDefinitions). These templates are part of the Horizon GPO Bundle (the file named VMware-Horizon-Extras-Bundle-version-something-something.zip)

Then you can use the "Edit group policy" app in Windows (just search for gpedit and should suggest it for you in Windows on the VM you are forwarding to) and edit the policies for: Computer Configuration > Administrative Templates > VMware View Agent Configuration > View USB Configuration > Client Downloadable Only Settings.

The entry in question is "Allow Keyboard and Mouse Devices", double click on it, a window appears where you can enable it (radio button), then can set from the drop-down below to "Allow - Default Client Setting". Apply and OK, then can close the editor.

I think you need to close the Horizon session and restart it, after that you should be able to see any keyboards and mice in the Horizon Client - Connect USB Device - menu. Select any of the ones you want, they get a tick-box next to their name and you should be able to see them as distinct devices in the VM, check with Device Manager in the VM. All done.

0 Kudos
scott28tt
VMware Employee
VMware Employee

I have reported your post to the moderators, asking them to move it to the area of the Communities for Horizon.

 


-------------------------------------------------------------------------------------------------------------------------------------------------------------

Although I am a VMware employee I contribute to VMware Communities voluntarily (ie. not in any official capacity)
VMware Training & Certification blog
0 Kudos