VMware Horizon Community

How remove old nodes from the Global Adam database?

I have a very irritating issue. Some old nodes are stil in the global Adam database but they are removed from Horizon.

If I run repadmin.exe /showrepl localhost:389 DC=vdi,DC=vmware,DC=int everything looks fine.

But if I run: repadmin.exe /showrepl localhost:22389 dc=vdiglobal,dc=vmware,dc=int I do get errors.



ource: Default-First-Site-Name\xxxx$VMwareVDMDSG
******* 64 CONSECUTIVE FAILURES since 2022-07-20 23:45:41
Last error: 1772 (0x6ec):
            The list of RPC servers available for the binding of auto handles has been exhausted.

Naming Context: CN=Schema,CN=Configuration,CN={xxx-xx-xx-xx-xxx}
Source: Default-First-Site-Name\xxx$VMwareVDMDSG
******* WARNING: KCC could not add this REPLICA LINK due to error.




I know this nodes and they are removed for about a year ago or similar and they are flooding my logs with errors as all of the other CS are trying to replicate to / from them.

I did remove them in the proper way.

They don't show up in Horizon View and vdmadmin -S -r -s don't work either.

Inside ADSIEdit for localhost:22389 under OU=Groups,OU=Properties,OU=Pod and then when I look under each pod they are not there either it's just my existing nodes there.

This is starting to drive me crazy!


Also tried to run query in the ADSI Edit (&(objectClass=pae-PodEndpoint)(cn=xxxx)) can't find anything


Edit 2:
Sovled it and made a blog post about it:


IT engineer that works with the hole VMWare portfolio and also loves to develop and automate in C# and PowerShell
Labels (4)
0 Kudos
0 Replies