Horizon Client - Microphone Found but No Sound Input


I'm trying to use the VMWare Horizon Client on arch-linux. I downloaded the VMWare-Horizon-Client-2203-8.5.0-19586897.x64.bundle and installed it. I'm using a Focusrite Scarlet for both my input and output sound interface.

When I was using the Horizon client on Windows everything worked fine. The same setup worked fine on Ubuntu before as well. I'm now using Manjaro and everything seems to be working except for my actual microphone input.

The microphone shows up in my devices as it had before but there's just no input ever being picked up. The device properly works on my machine--outside of the Horizon Client.

I also have a webcam that would show up before but is no longer showing up. I'm not worried about this as I don't use it but I figured it may help with troubleshooting.

I have the following packages installed:
vmware-horizon-client-2203-1  vmware-horizon-html5mmr-2203-1  vmware-horizon-integrated-printing-2203-1
            vmware-horizon-mmr-2203-1  vmware-horizon-rtav-2203-1  vmware-horizon-smartcard-2203-1
            vmware-horizon-teams-optimization-2203-1  vmware-horizon-tsdr-2203-1  vmware-horizon-usb-2203-1

From everything I've found while trying to fix this issue myself, I kept seeing mention of RTAV. I assume this would work though since it did work on Ubuntu.

The only difference I can think of specifically (other than the distro itself which I know can have many small differences) is that I'm using PipeWire and not PulseAudio. I'm also using a virtual microphone through Noisetorch to remove background noise. It doesn't seem to be working while Noisetorch is off either. The device name seems to match the non-virtual input as well, and I've verified switching my input to both the device directly and the virtual microphone on my desktop.

Here is a log of some of my audio info:

inxi -Aazy
 Device-1: NVIDIA GA102 High Definition Audio vendor: eVga.com.
   driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16
   link-max: gen: 4 speed: 16 GT/s bus-ID: 0f:00.1 chip-ID: 10de:1aef
   class-ID: 0403
 Device-2: AMD Starship/Matisse HD Audio vendor: ASRock
   driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
   bus-ID: 11:00.4 chip-ID: 1022:1487 class-ID: 0403
 Device-3: Logitech HD Pro Webcam C920 type: USB
   driver: snd-usb-audio,uvcvideo bus-ID: 3-5.1:5 chip-ID: 046d:082d
   class-ID: 0102 serial: <filter>
 Device-4: Focusrite-Novation Scarlett Solo (3rd Gen.) type: USB
   driver: snd-usb-audio bus-ID: 5-4:4 chip-ID: 1235:8211 class-ID: 0102
   serial: <filter>
 Sound Server-1: ALSA v: k5.15.32-1-MANJARO running: yes
 Sound Server-2: PulseAudio v: 15.0 running: no
 Sound Server-3: PipeWire v: 0.3.49 running: yes


I can try to supply any info needed but I think the main things are
1) microphone is working on my desktop
2) microphone appears in Horizon client (including 3rd party apps such as Webex) as "Microphone Array (Analogue 1 + 2 (Focusrite USB Audio) (VDI))"
3) microphone does not pick up input within Horizon Client
4) audio output through the same interface works
5) webcam is also not showing up for video/microphone

Thanks for any time spent reading/trying to help.

Labels (5)
0 Kudos
3 Replies
VMware Employee
VMware Employee

Expect a moderator to move your thread to the area for Horizon, now that I have reported it.



Although I am a VMware employee I contribute to VMware Communities voluntarily (ie. not in any official capacity)
VMware Training & Certification blog
0 Kudos

Sorry about that! Thanks for initializing the move!

0 Kudos

Install vmware-horizon-client and vmware-horizon-client-rtav and pipewire-pulse.

Had the same problem even after installing. Run

    pactl info

Note your default source. Run

    pactl list sources

Set the default to the one with the mic. Run

    pactl set-default-source name_of_the_source_from_the_list

No reboot or disconnect required.Check the sound levels on Windows 10 in Settings -> Sound -> Microphone. The monitor / volume bar for the mic should bounce when you speak.

0 Kudos