Contributor
Contributor

vmware-vmx high cpu usage causing Mac to heat up constantly

MacBook Pro Retina:

  • Model Name: MacBook Pro
  • Model Identifier: MacBookPro11,4
  • Processor Name: Intel Core i7
  • Processor Speed: 2.5 GHz
  • Number of Processors: 1
  • Total Number of Cores: 4
  • L2 Cache (per Core): 256 KB
  • L3 Cache: 6 MB
  • Memory: 16 GB

VMWare Fusion Professional Version 8.5.10 (7527438)

When I power-on the VM, MacBook fan starts to run very noisy and get machine hot. I've seen in Activity Monitor that a process "vmware-vmx" is hanging a lot of CPU (about 100-150% at any time).

I got a Windows 10 Enterprise VM with dedicated/allocated 2 cores and 8GB RAM. I power-on the virtual machine and min later the fans are running very fast and Activity Monitor shows that vmware-vmx is using +100% CPU.

I've tried to play with the resources, turn off accelerate 3D graphics but no result. What can I do to troubleshoot and how do I get to the root cause. This issue was not even noticeable a year ago but not sure what changed to all the sudden heat up and run high CPU.

Help please!

31 Replies
Leadership
Leadership

Hi,

Welcome at the VMware communities forum.

If the vmx process is consuming 100% CPU then usually it is something within the VM that consumes that CPU.

When the VM runs can you take a look at Windows task manager and in the "details" tab check which process is consuming most CPU?

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
Contributor
Contributor

I'm getting the same issue.  It's happened twice now where the VMware-vmx consumes 100%++ cpu.  The VM is actually booting at this time and is using 100%. Windows 10 desktop with nothing much in the way of apps running.

0 Kudos
Contributor
Contributor

I'm seeing this as well. Windows 10 VM is at maximum 1 to 2% CPU utilization, yet the Macbook Pro is showing vmware-vmx comsuming 40 to 70+% CPU and making the computer hot enough to cook bacon on.

0 Kudos
Leadership
Leadership

Hi StevenMBrown,

One thing to try is to reduce the total CPU core count if it is higher as 1.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
Contributor
Contributor

I have a 2.5 GHz i7 2015 15" MBP and have the exact same issue. It used to happen on my previous 2.4 GHz 2015 15" MBP as well.

This is a long standing issue. I have been facing this issue since 2015 and have upgrade from VMWare 8.x to 10.x (10.1.5 to be precise) but the issue has not been addressed.

Even when I have low CPU usage on the Windows side, VMWare still causes the fans to rev up.

The machine runs so hot that after about 5 minutes it becomes hard to type on and the fan noise starts to drive me crazy. It's okay if I want to quickly check something in Windows for 5-10 minutes, but it's almost unusable for longer period.

Now I'm going to start working on a new project where I'll probably spend more about 50% of my time on the Windows side, and with this issue it's not going to work for me.

Is there any solution to this?

0 Kudos
Contributor
Contributor

Same problem here.  Upgraded my Fusion 8 to Fusion 11.0.2 on Mojave. Client OS is Windows 7.  Windows 7 sits idle but vmware-vmx on my Mac goes through bursts of CPU ranging from 100% to 300%+.  I can try limiting the processor count to 1 (currently at 4) but that seems like a workaround, not a solution.  Also tried reinstalling VMWare tools but to no avail.  Seems like lots of people are having the same error with no updated from VMWare on this other than "it must be something on your VM that is running high CPU".

0 Kudos
Leadership
Leadership

What is the cpu% in the vms when this happens? I'm not sure if this is still relevent but check the default activity monitor application. Just double click on the relevant process on the list and select "Open Files and Ports" tab on the popup. See if its just accessing the vmx for the vm your using alot, or something else.

0 Kudos
Leadership
Leadership

Hi,

Drop your processor count to 2.

You're not mentioning your hardware, but it if it a laptop and it was upgraded to Mojave, then yes chances are reasonable that your 4 vCPU VM is causing the high CPU usage.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
Contributor
Contributor

Hello,

any solution for this issue?

I just bought fusion and I got this issue right away

any help will be appreciated!

0 Kudos
Contributor
Contributor

I lived with this problem for a long time and I just shied away from using Fusion. Finally got it resolved with help of Support. Incase someone finds this useful, it's possible that the Metal (hardware-accelerated 3D graphic and compute shader application programming interface in MacOS) is causing the performance issues.

Solution is to use OpenGL, since Metal API uses both OpenGL and OpenCL. There are two entries that have to be added in the .vmx file (configuration file) for the virtual machine. The steps are as follows :

1. First, the virtual machine should be shut down (not suspended or in sleep mode).

2. Then go the concerned virtual machine and click on show package contents (by doing a right click or using a single tap with two fingers).

3. Open the .vmx file with a Textedit, then from the top Apple menu bar go to Edit > Substitutions and make sure that Smart quotes are not enabled.

Add these lines at the end of the vmx file -

mks.enableMTLRenderer = "FALSE"

mks.enableGLRenderer = "TRUE"

Save the changes and power up the virtual machine.These changes will enable the graphics rendering using OpenGL.

Enthusiast
Enthusiast

This seems to also fix a problem I have been having with the XFCE window manager in Slackware --- any change from the default size of 800X600 resulted in "hash" lines on the bottom half of the screen and a cursor that decided to wander on its own.

Setting GL for rendering fixed it (and it runs cooler!!).

MacBook Pro 2015 - current Slackware, VMware 11.0.2

It appears that Apple's Metal and VMWare Fusion don't play quite right yet. OpenGL is fine for me.

0 Kudos
Contributor
Contributor

It did not resolve my issue. I am using the version 11 of VMware Fusion and I am at pain of using it. My MacBook Pro heats it up.

0 Kudos
Contributor
Contributor

I have exactly the same problem!

0 Kudos
Contributor
Contributor

Hey Folks,

I'm a complete Noob to vmware & fusion, I've only been using a few weeks so not sure how relevant this is.

I recently got a new 4k monitor for my macbook pro 13 and found that if I have the windows guest on the 4k screen I get this massive cpu drain on the mac even if the guest isnt doing much. a bit of investigation shows that the windows guest set the resolution to 7680x4198 if the window is fully expanded on the 4k screen. Manually changing this to either HD or UHD fixes the cpu problem but dosent let the guest use the entire screen so still trying to work that bit out.

Cheers

Matt

0 Kudos
Contributor
Contributor

Hi everyone,

I had the same issue - running OS X Mojave Version 10.14.5, and VMWare Fusion Version 11.1.1 (14328561).  I upgraded to this latest version of VMWare after running into the CPU spike of the vmware-vmx process (running well beyond 100% resulting in both vm and native OS freezing, unfreezing, system panic across the board, and all fans turning on on the MacBook Pro).  So I updated, and then re-installed VMWare tools on the VM (Ubuntu 19.04 Disco Dingo).

Just before I upgraded, I was able to open a terminal on the VM (Ubuntu) and ran "top" to see if I could identify the process spike - and thankfully the offending process was clearly visible as an "hgfs" process.  On the far left column of top is the PID (Process ID) which I noted, opened another terminal trying to complete before the system froze, and was able to type the command:

CLI Commands:

top

(Identify the top process monopolizing the CPU - it should be obvious @ 100%++ CPU utilization and note the PID)

sudo kill <pid>

(insert your pid number for <pid>.

On the "top" active terminal I immediately saw the hgfs process disappear, and CPU spike / root cause was truly terminated - the CPU spike nose dived back to normal "cool" levels - around 3% to 5% on the VM, and OS X host too in turn CPU nose dived back to normal levels.  Both systems after that were totally responsive and happy.

So thinking this may be an update issue, I updated everything to the latest on the VMWare Fusion side, and after the update re-installed the VMWare tools into the VM (Ubuntu 19.04).

My hope was that this was a fluke, and problem solved yesterday.  But this morning on startup of the VM the exact same thing happened, again the same hgfs process (with a different PID given the restart) but still the exact same CPU spike behavior.  I resolved the issue the same way, just killed the hgfs process in Ubuntu which was the root cause.  Even after killing the hgfs process, I can still access my shared drive (I have one shared drive in the root folder) so this truly looks like a semi-consistent startup issue.  Given my need for Ubuntu and general VM stability after killing the offending hgfs process I can manage, but I'm concerned the spike may recur during normal operating time.  For now I'm just keeping an eye in the VM with an open "top" terminal active so that if I suddenly hear the fans or notice what seems to be a CPU spike, I'm quickly aware of which PID and again resolve if needed.  Some additional information regarding versions below (within the Ubuntu 19.04 VM after installing the latest version of VMWare tools):


CLI Command:

/usr/bin/vmhgfs-fuse --version


Output:
/usr/bin/vmhgfs-fuse: version 1.6.6.0

FUSE library version: 2.9.9

fusermount version: 2.9.9

using FUSE kernel interface version 7.19

CLI Command:

/usr/bin/vmware-toolbox-cmd -v

Output:

10.3.10.10540 (build-12406962)

I hope this helps - and other than this issue in general performance of the VM with 4 cores allocated and 10GB memory has been stable with Ubuntu 19.04 Disco Dingo.

Good luck everyone!

Contributor
Contributor

this feels like a lot of different issues.

reinstalling the vmware tools fixed my high cpu at 4k issues however the random cpu spikes continued. the problem seems most pronounced on waking from a suspended state where the Mac slept or hibernated first.

yesterday I disabled "Accelerate 3d Graphics" setting and my system has been stable since, this is the longest I've gone without a cpu issue with Fusion but I will continue to monitor. I realise this may not suit everyone (if it is indeed the solution) but my win10 guest is a corporate image I need for domain access to my current project so 3d graphics arent an issue for me.

Cheers

Matt

0 Kudos
Contributor
Contributor

BluedevilX

Thank you so much for:

1. Working out this issue with support.

2. Posting about it.

I have had this issue since the last few years and this is the only thing that resolved it for me on my mbpro 2017.

You are fantastic!!!

0 Kudos
Contributor
Contributor

Complete VMware Fusion noob here:  I'm seeing a similar issue with the host CPU running problem.

MBP 2019 i7, 32GB RAM running Catalina v10.15

VMware Fusion 11.1.1

If I just open VMware Fusion - don't even start the VM - the host CPU goes nuts.  ('Nuts' is a technical term for fans running flat out.)

The "VMware Fusion Applications Menu" features high on the Activity Monitor's list of high CPU users, and top of the list of offenders of power consumption ("Energy Impact")

All this - and the guest OS hasn't even been started.  Quit VMware and the fans spin down and "Energy Impact" returns to a thin line at the bottom of the graph.

Does anyone have any ideas what's gone bad for me?

0 Kudos
Leadership
Leadership

Hi,


That problem "application menu taking up a lot of CPU" was mentioned before.

There are two ways for trying to resolve this.

.

The first one has been reported to work for Fusion 11.1.1 and is simply to disable the application menu

menu -> VMware Fusion -> Preferences -> General -> Applications menu: show in menu bar -> Never

The second one would be to upgrade to Fusion 11.5. It mentions support for Catalina, so I hope that VMware fixed it down there.

It's not mentioned in the release notes, so you might still have to resolve to the first option and disable the application menu.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva