issueman
Enthusiast
Enthusiast

vmware fusion 10.0.1 on macOS 10.13.1 not showing content of VMware Shared Folders

Jump to solution

Did enable a shared folder with Read & Write. As soon as I set that up "VMware Shared Folders" showed up on the vms desktop. But the shared folder is not displayed inside of that folder. This is really odd since in other vms this works as expected.

What can I do, to make this work as expected?

0 Kudos
1 Solution

Accepted Solutions
wila
Immortal
Immortal

Hi,

What's the guest OS?

You didn't mention that. There's a report of a similar known issue in a new VMware Tools, but for Ubuntu

Download VMware Tools 10.2.0

and from the readme:

  • Shared folder shows empty on Ubuntu17.04 with open-vm-tools
    On rebooting Ubuntu 17.04 with open-vm-tools installed, the shared folders /mnt directory is empty. This issue is observed even after installing Ubuntu 17.04 using easy install, enabling shared folders in VM settings and selecting Always Enabled.

But as you didn't mention the guest OS, it is most likely just Windows.

Not sure why you're seeing this.

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva

View solution in original post

0 Kudos
8 Replies
williamz
VMware Employee
VMware Employee

So far we couldn't reproduce the mentioned issue. Is this a 'special folder to share'? Any update or works now? Restarting guest OS helps? Power-cycled the VM? Thanks.

0 Kudos
issueman
Enthusiast
Enthusiast

sharing the default "downloads" folder from macOS. restarted vm various times. unticket sharing and re-enabled sharing. still no folder / content is shown. the same folder is shown for other vms.

0 Kudos
wila
Immortal
Immortal

Hi,

These type of issues are almost always due to a broken VMware Tools install.

Do not try a repair install from within the Guest OS as it likely will not fix this, unfortunately the "Reinstall VMware Tools" from the drop down menu also falls in that same category.

You really need the guest OS to reboot inbetween uninstall and install to make sure that all the files from VMware Tools are in the correct locations and of the correct version.

In short follow these steps:

  • Uninstall VMware Tools
  • Reboot guest OS
  • Install VMware Tools
  • Reboot guest OS.

Follow the steps from the installer to completely uninstall VMware Tools 

  • Reboot the guest OS.
  • Then from the Virtual Machine menu select "Install VMware Tools"

If no installer appears, go to the DVD-rom within windows and click "setup" (for 32 bits windows) or "setup64" (for 64 bits windows)

Once you see an installer, click "Next" until Finish, keep the defaults.

  • Reboot the guest when done installing (it will ask by itself to reboot)

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
issueman
Enthusiast
Enthusiast

Thanks wila

Tried that.

  • uninstalled vmware tools
  • reboot vm
  • install vmware tools
  • reboot vm
  • wasn't working yet, so disabled sharing
  • reboot vm
  • re-enable sharing


Still no luck. The linked folder appears on desktop but the shared standards downloads folder still does not show up inside of that. Added other folders in Preferences > Sharing but nothing shows up. Again, this is working in all other vms. 😕

0 Kudos
wila
Immortal
Immortal

Hi,

What's the guest OS?

You didn't mention that. There's a report of a similar known issue in a new VMware Tools, but for Ubuntu

Download VMware Tools 10.2.0

and from the readme:

  • Shared folder shows empty on Ubuntu17.04 with open-vm-tools
    On rebooting Ubuntu 17.04 with open-vm-tools installed, the shared folders /mnt directory is empty. This issue is observed even after installing Ubuntu 17.04 using easy install, enabling shared folders in VM settings and selecting Always Enabled.

But as you didn't mention the guest OS, it is most likely just Windows.

Not sure why you're seeing this.

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
issueman
Enthusiast
Enthusiast

vm: macOS 10.13

Thanks for the link. Downloaded vmware tools for macOS (zip).

uninstalled

restarted

installed VMware Tools 10.2.0

restarted

ran into message about blocked system extension. opened system preferences and allowed system extension.

another restart was required. then and only then did the shared folder re-appear.

thanks a lot for your help and linking me the newer version of the vmware tools.

0 Kudos
wila
Immortal
Immortal

Hi,

Ahh.. OK, macOS guest, suppose that was what you meant in the subject of this thread. I read that as being the host OS Smiley Happy

Perhaps the "blocked system extension" was the culprit for the old VMware Tools too.

Not that that matters much at this stage as you now have a working setup, but it is something I will keep in mind next time somebody remarks the issue.

FWIW, I have 10.13 guests with working shared folders where I did not update the tools to this new version yet.

So it can work.

Glad to hear you have it to work now too.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
issueman
Enthusiast
Enthusiast

Yeah, the host OS / vm OS part was indeed unclear. And you actually read it correctly as host OS Smiley Happy. In this case both host and vm are macOS although the thread title was only referring to host.

0 Kudos