easyrunner
Contributor
Contributor

vmware fusion 1.1 + bootcamp ntfs issue

Jump to solution

Hello,

I have been using vmware fusion 1.0 since August. I recently upgraded to VMware fusion 1.1 and updated the Windows XP boot camp partition from FAT32 to NTFS. Now I'm unable to start the boot camp partition as a vmware fusion virtual machine.

Everytime I try to startup vmware fusion with boot camp virtual machine I get a very generic exception message "A failure occured during preprocessing: An unknown error occurred.."

I have tried the following,

1. Delete all the vmware virtual machine files for bootcamp as per the document by etung, also deleted the bootcamp partition item from the virtual machine listing.

2. Uninstalled vmware fusion and reinstalled.

Nothing seems to help. Any thoughts or suggestions from others ?

Thanks

0 Kudos
1 Solution

Accepted Solutions
rcardona2k
Immortal
Immortal

In scanning it your vmware.log looks normal to me. I know other users have experienced issues when converting FAT to NTFS within Boot Camp. You could try manually creating a VM that accesses your Boot Camp partition by going through the New Machine Wizard and changing out the placeholder virtual hard disk with the Boot Camp partition with the steps at the end of this thread:

View solution in original post

0 Kudos
7 Replies
rcardona2k
Immortal
Immortal

In the Finder, use the Go menu > Go to folder... option and enter this location: ~/Library/Application Support/VMware Fusion/Virtual Machines

You should have a Boot Camp and a Helper folder. In the Helper folder there's a VM bundle called naos-1.0.vmwarevm. Open that VM bundle and attach the vmware.log within as a file attachment in your reply using the "Choose File" button at the bottom of the window.

Thanks

0 Kudos
easyrunner
Contributor
Contributor

Thanks for the quick response, I have attached the vmware log file from helper VM package.

0 Kudos
easyrunner
Contributor
Contributor

Here is some additional information regarding the hardware/software setup,

Hardware Overview:

Model Name: MacBook Pro 15"

Model Identifier: MacBookPro2,2

Processor Name: Intel Core 2 Duo

Processor Speed: 2.33 GHz

Number Of Processors: 1

Total Number Of Cores: 2

L2 Cache (per processor): 4 MB

Memory: 2 GB

Bus Speed: 667 MHz

Boot ROM Version: MBP22.00A5.B07

SMC Version: 1.12f5

System Software Overview:

System Version: Mac OS X 10.4.11 (8S2167)

Kernel Version: Darwin 8.11.1

Boot Volume: Macintosh HD

Vmware:

Version: 1.1

Last Modified: 11/25/07 3:50 PM

Kind: Intel

Location: /Applications/VMware Fusion.app

Boot camp:

Windows XP-SP2 Home edition

32 GB NTFS partition (initially FAT32).

I can boot directly to the NTFS partition without any problems.

0 Kudos
rcardona2k
Immortal
Immortal

In scanning it your vmware.log looks normal to me. I know other users have experienced issues when converting FAT to NTFS within Boot Camp. You could try manually creating a VM that accesses your Boot Camp partition by going through the New Machine Wizard and changing out the placeholder virtual hard disk with the Boot Camp partition with the steps at the end of this thread:

0 Kudos
easyrunner
Contributor
Contributor

Hi Richard,

That suggestion worked for me, I had to use vi through terminal to edit the file to remove the Control character that gets pasted if you copy and paste the two configuration parameters,

snapshot.disabled = "TRUE"

suspend.disabled = "TRUE",

I hope the next release of fusion will incorporate a more helpful error message or fix this automatically.

Thanks for your help, you guys are really very helpful,

0 Kudos
rcardona2k
Immortal
Immortal

Copy and pasting multiple lines out of the forums, particularly with Firefox 2.0 is a long-since known problem. For editing the .vmx file, I highly recommend using a professional text editor like TextWrangler (free) or BBEdit. vi works well too Smiley Happy

0 Kudos
fychan
Contributor
Contributor

Hi There I'm also facing the same issue for the Unknown pre-processing error.

I have even re-installed my Vista in boot camp but it still doesn't work.

And even re-installed my OSX still doesn't work...

I have also remove the bootcamp files and tried re-creating the bootcamp image it still fails with the same error.

there are no logs captured all i see inside the boot camp folder are 2 vmdk files.

Please advice...

0 Kudos