raphael9
Contributor
Contributor

vmhgfs mount path with osx guest

Jump to solution

Hi,

Using OSX server guest, mount_vmhgfs always mounts the root directory of the Shared Folders instead of the specific folder:

For example mount -t vmhgds .host:/test /Volumes/test will mount .host:/ instead of .host:/test in /Volumes/test

Is there a workaround for such behavior?

Thanks!

0 Kudos
1 Solution

Accepted Solutions
steve_goddard
Expert
Expert

HI there,

I am the developer for this feature.

The short answer is that I don't think that part of the file sharing feature has ever really worked or been fully tested and supported for OS X guest VMs.

It does work for Windows VMs that I am certain of and has been there for quite some time. It also looks like Linux VMs work too.

Sorry to say that I don't see any workaround either.

I have a bug now requesting this enhancement at your mention of it here.

Looking into the history of source code changes in this area, it looks like some were made a long time ago for Linux but was not done for OS X.

I hope that will mean that it somewhat implemented and may just need fixing rather than fully implementing anew.

So I will schedule some time to investigate what I can do to address this.

Steve

Thanks. Steve

View solution in original post

0 Kudos
2 Replies
steve_goddard
Expert
Expert

HI there,

I am the developer for this feature.

The short answer is that I don't think that part of the file sharing feature has ever really worked or been fully tested and supported for OS X guest VMs.

It does work for Windows VMs that I am certain of and has been there for quite some time. It also looks like Linux VMs work too.

Sorry to say that I don't see any workaround either.

I have a bug now requesting this enhancement at your mention of it here.

Looking into the history of source code changes in this area, it looks like some were made a long time ago for Linux but was not done for OS X.

I hope that will mean that it somewhat implemented and may just need fixing rather than fully implementing anew.

So I will schedule some time to investigate what I can do to address this.

Steve

Thanks. Steve

View solution in original post

0 Kudos
raphael9
Contributor
Contributor

Thank you for the reply Steve.

Looking forward to seeing a fix in a future release of the tools 🙂

0 Kudos