Highlighted
Contributor
Contributor

unable to compile vmware hgfs driver on Debian wheezy with kernel 3.2.0-4-amd64, vmware fusion 7.1.1 and latest vmware-tools

Hello.

Everything is in the title. I wanted to recompile vware tools because copy and paste was not working anymore after kernel upgrade. But the recompile failed and I lost hgfs support.

Here is the error :

make: entrant dans le répertoire « /tmp/modconfig-ihecbM/vmhgfs-only »

/usr/bin/make -C /lib/modules/3.2.0-4-amd64/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. \

      MODULEBUILDDIR= modules

make[1]: entrant dans le répertoire « /usr/src/linux-headers-3.2.0-4-amd64 »

  CC [M]  /tmp/modconfig-ihecbM/vmhgfs-only/backdoorGcc64.o

  CC [M]  /tmp/modconfig-ihecbM/vmhgfs-only/backdoor.o

  CC [M]  /tmp/modconfig-ihecbM/vmhgfs-only/bdhandler.o

  CC [M]  /tmp/modconfig-ihecbM/vmhgfs-only/cpName.o

  CC [M]  /tmp/modconfig-ihecbM/vmhgfs-only/cpNameLinux.o

  CC [M]  /tmp/modconfig-ihecbM/vmhgfs-only/cpNameLite.o

  CC [M]  /tmp/modconfig-ihecbM/vmhgfs-only/dentry.o

  CC [M]  /tmp/modconfig-ihecbM/vmhgfs-only/dir.o

  CC [M]  /tmp/modconfig-ihecbM/vmhgfs-only/file.o

  CC [M]  /tmp/modconfig-ihecbM/vmhgfs-only/filesystem.o

  CC [M]  /tmp/modconfig-ihecbM/vmhgfs-only/fsutil.o

  CC [M]  /tmp/modconfig-ihecbM/vmhgfs-only/hgfsBd.o

  CC [M]  /tmp/modconfig-ihecbM/vmhgfs-only/hgfsEscape.o

  CC [M]  /tmp/modconfig-ihecbM/vmhgfs-only/hgfsUtil.o

  CC [M]  /tmp/modconfig-ihecbM/vmhgfs-only/inode.o

  CC [M]  /tmp/modconfig-ihecbM/vmhgfs-only/link.o

/tmp/modconfig-ihecbM/vmhgfs-only/inode.c: In function ‘HgfsPermission’:

/tmp/modconfig-ihecbM/vmhgfs-only/inode.c:1983:34: error: ‘struct dentry’ has no member named ‘d_alias’

/tmp/modconfig-ihecbM/vmhgfs-only/inode.c:1983:34: warning: initialization from incompatible pointer type [enabled by default]

/tmp/modconfig-ihecbM/vmhgfs-only/inode.c:1983:34: warning: (near initialization for ‘dentry’) [enabled by default]

/tmp/modconfig-ihecbM/vmhgfs-only/inode.c:1983:34: error: ‘struct dentry’ has no member named ‘d_alias’

make[4]: *** [/tmp/modconfig-ihecbM/vmhgfs-only/inode.o] Erreur 1

make[4]: *** Attente des tâches non terminées....

make[3]: *** [_module_/tmp/modconfig-ihecbM/vmhgfs-only] Erreur 2

make[2]: *** [sub-make] Erreur 2

make[1]: *** [all] Erreur 2

make[1]: quittant le répertoire « /usr/src/linux-headers-3.2.0-4-amd64 »

make: *** [vmhgfs.ko] Erreur 2

make: quittant le répertoire « /tmp/modconfig-ihecbM/vmhgfs-only »

I think the problem should lie in version numbering test. For security reason, Debian security team backport some changes to kernel, and it seems there is a conflict there between the different numberings

I've tried for the whole afternoon everything I googled. Usually, I've always managed theses three last years to find alone a solution. But

* installing debian open-vm-tools does not work

* the patches from rasa/vmware-tools-patches · GitHub neither

After a whole afternoon, I decided to call for your wisdom.

Thanks in advance

Laurent

Tags (2)
0 Kudos
2 Replies
Highlighted
Contributor
Contributor

I think the closest answer was probably

Re: VMware Tools Compile Problem

but the patch proposed in this place doesn't exist anymore. I've tried the newest rasa patches, but couldn't get it to work (alas)

0 Kudos
Highlighted
Contributor
Contributor

0 Kudos