tried fixes not working - peer process error


Tried all the fixes of deleting system lib/prefs files and uninstalling and reinstalling and restarting but still get "fail to connect to peer process" error.

What is going on???? thanks

Am running OSX server 10.5.1 server

0 Kudos
1 Reply

The two reasons I've come across this problem with are:

>1. VMware Fusion network is down when you start the virtual machine, which is fixed by either --restart or rebooting (one-time fixes), or re-installing Fusion (if chronic).

Sounds like you tried this.

2. File/Folder permissions problems with the virtual machine files.

Try these steps to fix your permissions problem:

1. Shutdown your VM

2. Find your VM's icon under Virtual Machines and click on it to highlight it and choose File > Get Info in the Finder

3. When the VM's Info window comes up in "Name & Extension" remove the ".vmwarevm" part of the name.

4. Close the Info window, confirm you want to remove the extension and your VM's icon should now be a folder icon.

5. Get Info on the VM "folder" and open the triangle twistie under "Ownership & Permissions" to access the "Details" triangle twistie.

6. Open Details, verify you're the Owner with Read & Write access.

7. Click on "Apply to enclosed items" and confirm you want to apply permissions and if necessary authenticate yourself with your login.

(See attachment below for reference on this step)

8. Before closing Info, go back to "Name & Extension" and re-add ".vmwarevm", close the Info window

9. Click "Add" to restore the vmwarevm extension when prompted.

Try using your VM again.

0 Kudos