VMware Communities
oaklodge
Enthusiast
Enthusiast
Jump to solution

static Linux guest IP address

Using Fusion 13.5 I have created a new install of Debian 12.

How do I assign debian a static IP address

I am currently using "Share with my Mac"

0 Kudos
1 Solution

Accepted Solutions
Technogeezer
Immortal
Immortal
Jump to solution

That’s the right file. Use the advice in https://communities.vmware.com/t5/VMware-Fusion-Discussions/Unable-to-set-static-IP-addresses-on-gue...

(replace xx:xx:xx:xx:xx:xx with the MAC address of the virtual NIC which you can find in the VM). 

- Paul (Technogeezer)
Editor of the Unofficial Fusion Companion Guides

View solution in original post

3 Replies
Technogeezer
Immortal
Immortal
Jump to solution

"Share with my Mac" means that you are using NAT networking. That creates a dedicated subnet with a NAT "gateway" that allows you to communicate with the outside world (similar to what you'd get on a home Internet cable router).

You have two choices:

  1. Configure the VM's network adapter manually (without using DHCP) through the network utiliies provided with Debian.
    Configure the VM with an IP address outside the range being handed out by Fusion's DHCP server for the NAT network. (for the stock Fusion configuration, that means you should pick an address from xxx.xxx.xxx.3 through xxx.xxx.xxx.127).
    Configure both the the gateway and the DNS server to xxx.xxx.xxx.2.
  2. A more complex solution is to configure the Fusion DHCP server to always give out the same IP address for your VM. That involves editing the NAT networks dhcp.conf file.

I'd recommend 1. unless you are sufficiently technical to understand how to configure the DHCP service. 

- Paul (Technogeezer)
Editor of the Unofficial Fusion Companion Guides
0 Kudos
oaklodge
Enthusiast
Enthusiast
Jump to solution

Thanks for the helpful ideas. Where do I find the parameters for the Fusion DHCP server?

I ended up editing the /Library/Preferences/VMware Fusion/vmnet8/dhcpd.conf and for completeness I also edited /etc/hosts file on the mac

0 Kudos
Technogeezer
Immortal
Immortal
Jump to solution

That’s the right file. Use the advice in https://communities.vmware.com/t5/VMware-Fusion-Discussions/Unable-to-set-static-IP-addresses-on-gue...

(replace xx:xx:xx:xx:xx:xx with the MAC address of the virtual NIC which you can find in the VM). 

- Paul (Technogeezer)
Editor of the Unofficial Fusion Companion Guides