jcverdie
Contributor
Contributor

shared folders are not visible after reboot

Jump to solution

Hi

 

I'm using Fusion Pro 12.2.1

Host= MacOS (Monterey 12.4)

Guest= Ubuntu 22

 

I have a shared folder. Everytime I boot the guest os, I cannot see it under /mnt/hgfs

 

When I go to settings -> uncheck "enable shared folders" -> re-check "enable shared folders", then it comes back and the shared folder is available again..

 

Is there anything I might be missing ? I browsed the support forum and can't find a hint...

Labels (3)
0 Kudos
1 Solution

Accepted Solutions
wila
Immortal
Immortal

Hi,

Known issue... for a while too.

https://docs.vmware.com/en/VMware-Tools/11.3/rn/VMware-Tools-1130-Release-Notes.html

VMware Tools Issues in VMware Workstation or Fusion

Shared Folders mount is unavailable on Linux VM. If the Shared Folders feature is enabled on a Linux VM while it is powered off, the shared folders mount is not available on restart.

Note: This issue is applicable to VMware Tools running on Workstation and Fusion.

Workaround:

If the VM is powered on, disable and enable the Shared Folders feature from the interface. For resolving the issue permanently, edit /etc/fstab and add an entry to mount the Shared Folders automatically on boot.

For example, add the line:

vmhgfs-fuse   /mnt/hgfs    fuse    defaults,allow_other    0    0

Before you do that, you might want to check that things are setup correctly. Try running the following:

sudo mkdir -p /mnt/hgfs/
sudo /usr/bin/vmhgfs-fuse .host:/ /mnt/hgfs/ -o subtype=vmhgfs-fuse,allow_other


also see:

https://kb.vmware.com/s/article/74650

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva

View solution in original post

3 Replies
ravipadigela
Enthusiast
Enthusiast

it most cases now facing same issue, try to Update or reinstall VM tools 

follow article and install tools manually 

https://kb.vmware.com/s/article/1022525

to download latest VM tools:

https://customerconnect.vmware.com/en/downloads/info/slug/datacenter_cloud_infrastructure/vmware_too...

0 Kudos
wila
Immortal
Immortal

Hi,

Known issue... for a while too.

https://docs.vmware.com/en/VMware-Tools/11.3/rn/VMware-Tools-1130-Release-Notes.html

VMware Tools Issues in VMware Workstation or Fusion

Shared Folders mount is unavailable on Linux VM. If the Shared Folders feature is enabled on a Linux VM while it is powered off, the shared folders mount is not available on restart.

Note: This issue is applicable to VMware Tools running on Workstation and Fusion.

Workaround:

If the VM is powered on, disable and enable the Shared Folders feature from the interface. For resolving the issue permanently, edit /etc/fstab and add an entry to mount the Shared Folders automatically on boot.

For example, add the line:

vmhgfs-fuse   /mnt/hgfs    fuse    defaults,allow_other    0    0

Before you do that, you might want to check that things are setup correctly. Try running the following:

sudo mkdir -p /mnt/hgfs/
sudo /usr/bin/vmhgfs-fuse .host:/ /mnt/hgfs/ -o subtype=vmhgfs-fuse,allow_other


also see:

https://kb.vmware.com/s/article/74650

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
jcverdie
Contributor
Contributor

That's the exact thing to do, thanks a million and apologies for not being able to find the correct forum message...

0 Kudos