Highlighted
Enthusiast
Enthusiast

reset IP address assigned via DHCP _always_ to same host

Jump to solution

I have 3 hosts:  h1, h2, h3. They get their IP addresses via DHCP on a host-only vnet. First time I started them I did in this order h1, h3, h2 so they got addresses ending in .142, .143 and .144 respectively. Now everytime I boot them they get the same IPs no matter which order they boot. How can I reset this? (I want to start h2 second to get .143).

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Virtuoso
Virtuoso

You may want to look at the file

/var/db/vmware/vmnet-dhcpd-vmnet1.leases

What you do with that file you are on your own.

View solution in original post

0 Kudos
4 Replies
Highlighted
Virtuoso
Virtuoso

You may want to look at the file

/var/db/vmware/vmnet-dhcpd-vmnet1.leases

What you do with that file you are on your own.

View solution in original post

0 Kudos
Highlighted
Immortal
Immortal

your question is not clear about DHCP server . If you have windows DHCP server than follow-up below process to remove DHCP lease for h2, h3.

You can also manually delete the leases. Perform the following steps: 

  1. Start the Microsoft Management Console (MMC) DHCP snap-in (Start, Programs, Administrative Tools, DHCP).
  2. Select the Scope that contains the leases to be deleted.
  3. Select the Address Leases container.
  4. Right-click the lease to be deleted and select Delete.
  5. Click OK to the confirmation.

Regards,

Randhir

If you found my answers useful please consider marking them as Correct OR Helpful

0 Kudos
Highlighted
Enthusiast
Enthusiast

I just moved /var/db/vmware/vmnet-dhcpd-vmnet* away and let Fusion recreate them.

0 Kudos
Highlighted
Enthusiast
Enthusiast

I also had to delete the hashes (VNET_x_DHCP_CFG_HASH) from /Library/Preferences/VMware Fusion/networking, otherwise the Network Adapter settings will be greyed out (see Network Settings options greyed out…). Also, make sure that neither Fusion nor vmnet* processes are running, or quit/kill them before you modify any file.

0 Kudos