ecterrab
Contributor
Contributor

remapping "ungrab mouse and keyboard" from Command - Control to something else?

Hi,

I have windows applications installed which use Ctrl-Cmd for its shortcuts (that is, Ctrl - Windows). Each time I use those shortcuts within the virtual machine, Fusion quits its Full Scree mode. I tried Fusion -> Preferences -> Fusion Shortcuts but I see this shortcut is greyed and it seems not possible to change it in this preference window (double click or right click also didn't work for that purpose). So how can I remap the "Ungrab Mouse and Keyboard" Fusion Shortcut from "Command - Control" to something else? Or, if that is not possible, then turn this shortcut off? Thanks.

0 Kudos
11 Replies
borisdusek
Expert
Expert

This might solve your issue: open the "Key mappings" tab in Fusion's "Keyboard & mouse" settings section, click the plus sign to add a new mapping, and map anything that you like to CtrlWin, i.e. ShiftSpace. Then try your app to see if it's working (i.e. you will press ShiftSpace instead of CtrlApple, and it will get translated in Windows into CtrlWin, CommandApple will stay for ungrab).

0 Kudos
ecterrab
Contributor
Contributor

Hi thanks for the suggestion; I tried that before posting and didn't succeed. It seems to me it is not possible to map Control - Command from within the Fusion -> Preference -> Key mappings.

0 Kudos
markshel
VMware Employee
VMware Employee

Thank you for your feedback. Unfortunately there is currently no way to change the ungrab key mapping in Fusion 2.0. We are looking into implementing this feature though I can not comment on future releases. This issue is being tracked internally as bug 336758.

As a workaround I would recommend mapping Option to Windows as well as Windows to Option. With these key bindings set Control-Command will still ungrab like it did before and you will be able to send Control-Windows to Windows by pressing Control-Option without ungrabbing. These key mappings can be set in Preferences -> Keyboard & Mouse -> Key Mappings.

bstein
Contributor
Contributor

I do not see how to implement your workaround. It's possible to remap Opt to Win but how do you remap Win to Opt when Win as the From key isn't an "option"--did you mean another key combo? Or is Fusion supposed to detect whether a PC keyboard is connected but for some reason it isn't?

And is Ungrab Mouse and Keyboard supposed to exit Full Screen? This behavior is extremely annoying (I tend to hit it by mistake).

Please make all keyboard shortcuts togglable as well as customizable.

0 Kudos
onewheelskyward
Contributor
Contributor

Well, it's now been 2.5 years.  Have you guys fixed this yet?  Can you give us the status of bug 336758?  I'm using VMWare Fusion 4.0 and I don't see a way to change keystrokes, which is an industry standard/best practice at this point.

0 Kudos
vmQuint
Enthusiast
Enthusiast

Three more years have gone by.  I'm in Fusion 6, but I think 7 is out, right?  Is it possible yet? 

0 Kudos
eamodio
Contributor
Contributor

It is now the middle of 2015 and Fusion 8 is out and you STILL can't remap those keys. Which is a huge issue because Windows 10 uses Control+Windows for many shortcuts.

0 Kudos
f1yankees
Contributor
Contributor

I still don't see an easy way to do this - have they really not added it or am I missing something?  Fusion 8.5 Pro.

0 Kudos
DavidStorm
Contributor
Contributor

It has now been 12 years. I still don't see this feature. It would be very helpful.

0 Kudos
kiwi45
Contributor
Contributor

Still not able to remap this in version 12.

0 Kudos
JohnDoe0
Contributor
Contributor

VMware, doesn't Care