Highlighted
Enthusiast
Enthusiast

reinstalling or uninstalling or upgrading tools?

Jump to solution

I just installed linuxmint 18.3 and as usual installed tools after install had finished. I am pretty sure it installed

I now get CANCEL TOOLS INSTALLATION grayed out in the Virtual Machine menu, on all subsequent reboots, which I thought was normal?

But I cant share folders in the host?? I can enable the folder on the host in SHARING but I get a message telling me I cant share until I install tools??

Is there an FAQ on reinstalling or uninstalling or upgrading tools please?

1 Solution

Accepted Solutions
Highlighted
User Moderator
User Moderator

Hi,

That's the correct place for the  mounting, but not for running the vmware tools install script.

If you run:

ls /mnt/cdrom

Do you then get a list that includes VMwareTools-xxxxxx.tar.gz ?

(where xxxxx is some number) If not then don't mind the other steps.

In that case please return the output of "df -h"

If OTOH you get the correct output then let's try again (and I'll explain the steps this time)

  1. cd ~ 
  2. cp /mnt/cdrom/VMwareTools-*.tar.gz . 
  3.  
  4. tar -xvf VMwareTools-*.tar.gz 
  5. cd vmware-tools-distrib/ 
  6. sudo apt-get update 
  7. sudo apt-get upgrade 
  8. sudo apt-get install build-essential linux-headers-`uname -r` 
  9. sudo ./vmware-install.pl --default 

cd ~ --> change directory to your home folder

cp /mnt/cdrom/VMwareTools-*.tar.gz . --> that copies the tar.gz file to the current directory (.) don't miss the dot Smiley Happy

tar -xvf VMwareTools-*.tar.gz --> unpack the tar.gz file. This should create a folder vmware-tools-distrib in your home folder

cd vmware-tools-distrib --> change into the folder that has the actual scripts and code for vmware-tools

the sudo apt-get lines are for getting the latest software packages and the line with build-essential etc. pulls in the compilers and make tools etcetera for being able to compile the source.

sudo ./vmware-install.pl --default --> starts the compilations and install of vmware tools.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva

View solution in original post

45 Replies
Highlighted
Expert
Expert

Probably the Tools didn't install properly: why not simply try to install them again? If the menu is not accessible, you can mount the Tools ISO image directly from /Applications/VMware\ Fusion.app/Contents/Library/isoimages/linux.iso (if necessary, copy the ISO to another folder first).

Anyway, IIRC, the preferred method of installing the Tools on Linux is to first install the Open VM Tools (sudo apt install open-vm-tools-desktop), restart the VM, and then, if you need the VMware Shared Folders, also install the VMware Tools (from the menu, or by mounting the Tools ISO image manually): this should install only the required components for the shared folders, while maintaining the functionality of the Open VM Tools.

Highlighted
User Moderator
User Moderator

Hi,

Sven is correct. Just a few small tidbits though.

Before installing open-vm-tools (and for features like drag&drop, etc.. open-vm-tools-desktop) I do recommend to completely uninstall the VMware Tools bundled with VMware Fusion.

In addition open-vm-tools does include shared folders nowadays as well.

On any recent Linux VM, you should normally not need to install the bundled VMware Tools anymore.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
Highlighted
Enthusiast
Enthusiast

Thanks for that but I am still going around in circles!  Tools still wont install properly in that I cant share files with the host.

I did manage to execute the command in terminal. It didnt seem to think tools were installed and it installed them. Still no sharing. I restarted. Still no sharing. RE-install tools was now available from the tools menu so I pressed it. Still no sharing. So I restarted. Still no sharing. cancel vmware tools installation was now greyed out in Menu; So, to check, I tried executing the command again in terminal.  It found tools was properly installed, not upgradable and it did nothing. Still no sharing. So I restarted again, but Still no sharing.

cancel vmware tools installation still greyed out in Menu, even after a few restarts??  Do you have any idea what I am doing wrong please?

0 Kudos
Highlighted
Enthusiast
Enthusiast

Thanks for that, I did  know that you shouldnt have to install tools separately any more and I have never done this before.  In the past I thought you only ever needed to install tools again if Fusion was updated.  To update tools or re-install tools.  Which is why I am wondering why I am having these problems

0 Kudos
Highlighted
Expert
Expert

Here is a link for uninstalling the Tools:

VMware Knowledge Base

...or:

sudo /usr/bin/vmware-uninstall-tools.pl

After uninstalling them and rebooting the guest, you can try to install the Open VM Tools (the open-vm-tools-desktop package, which also installs all dependencies), reboot the guest and see if this also gives shared folders; if not, try to install the VMware Tools on top, reboot and see if everything works.

Highlighted
Expert
Expert

Didn’t know that the Open VM Tools now also include VMware Shared Folders: that would indeed be a very good thing (will try and see next time I install a new Linux VM)...

(But probably it’s not an automatic feature, as when you install the VMware Tools in addition to the Open VM Tools, with the shared folders appearing in /mnt/hgfs: maybe it requires some manual Terminal command to mount the shared folders...?)

Highlighted
Enthusiast
Enthusiast

Still getting nowhere

Your command sudo /usr/bin/vmware-uninstall-tools.pl gives a no such command error message and on the page you sent me to, su - root just gives an authentication failure when I enter what i know to be  my password.

I tried sudo /usr/bin/vmware-uninstall-tools.pl both before and after sudo bash, with no improvement!

0 Kudos
Highlighted
Enthusiast
Enthusiast

Does this show why I am getting error messages?

ugo@hugo-virtual-machine ~ $ locate vmware

/etc/vmware-tools

/etc/vmware-tools/guestproxy-ssl.conf

/etc/vmware-tools/poweroff-vm-default

/etc/vmware-tools/poweron-vm-default

/etc/vmware-tools/resume-vm-default

/etc/vmware-tools/scripts

/etc/vmware-tools/statechange.subr

/etc/vmware-tools/suspend-vm-default

/etc/vmware-tools/tools.conf

/etc/vmware-tools/vm-support

/etc/vmware-tools/xautostart.conf

/etc/vmware-tools/scripts/vmware

/etc/vmware-tools/scripts/vmware/network

/etc/xdg/autostart/vmware-user.desktop

/usr/bin/vmware-checkvm

/usr/bin/vmware-guestproxycerttool

/usr/bin/vmware-hgfsclient

/usr/bin/vmware-namespace-cmd

/usr/bin/vmware-rpctool

/usr/bin/vmware-toolbox-cmd

/usr/bin/vmware-user-suid-wrapper

/usr/bin/vmware-vmblock-fuse

/usr/bin/vmware-xferlogs

/usr/bin/vmwarectrl

/usr/lib/xorg/modules/drivers/vmware_drv.so

/usr/share/app-install/icons/_usr_share_pixmaps_vmware-player.png

/usr/share/bug/xserver-xorg-video-vmware

/usr/share/bug/xserver-xorg-video-vmware/script

/usr/share/doc/xserver-xorg-video-vmware

/usr/share/doc/xserver-xorg-video-vmware/changelog.Debian.gz

/usr/share/doc/xserver-xorg-video-vmware/copyright

/usr/share/grub-gfxpayload-lists/blacklist/10_vmware

/usr/share/man/man1/vmware-checkvm.1.gz

/usr/share/man/man1/vmware-toolbox-cmd.1.gz

/usr/share/man/man1/vmware-user-suid-wrapper.1.gz

/usr/share/man/man1/vmware-xferlogs.1.gz

/usr/share/man/man4/vmware.4.gz

/usr/src/linux-headers-4.10.0-38-generic/include/config/vmware

/usr/src/linux-headers-4.10.0-38-generic/include/config/infiniband/vmware

/usr/src/linux-headers-4.10.0-38-generic/include/config/infiniband/vmware/pvrdma.h

/usr/src/linux-headers-4.10.0-38-generic/include/config/vmware/balloon.h

/usr/src/linux-headers-4.10.0-38-generic/include/config/vmware/pvscsi.h

/usr/src/linux-headers-4.10.0-38-generic/include/config/vmware/vmci

/usr/src/linux-headers-4.10.0-38-generic/include/config/vmware/vmci.h

/usr/src/linux-headers-4.10.0-38-generic/include/config/vmware/vmci/vsockets.h

/usr/src/linux-headers-4.13.0-37-generic/include/config/vmware

/usr/src/linux-headers-4.13.0-37-generic/include/config/infiniband/vmware

/usr/src/linux-headers-4.13.0-37-generic/include/config/infiniband/vmware/pvrdma.h

/usr/src/linux-headers-4.13.0-37-generic/include/config/vmware/balloon.h

/usr/src/linux-headers-4.13.0-37-generic/include/config/vmware/pvscsi.h

/usr/src/linux-headers-4.13.0-37-generic/include/config/vmware/vmci

/usr/src/linux-headers-4.13.0-37-generic/include/config/vmware/vmci.h

/usr/src/linux-headers-4.13.0-37-generic/include/config/vmware/vmci/vsockets.h

/var/lib/dpkg/info/xserver-xorg-video-vmware.conffiles

/var/lib/dpkg/info/xserver-xorg-video-vmware.list

/var/lib/dpkg/info/xserver-xorg-video-vmware.md5sums

/var/log/vmware-vmsvc.1.log

/var/log/vmware-vmsvc.2.log

/var/log/vmware-vmsvc.log

0 Kudos
Highlighted
User Moderator
User Moderator

Hi,

I don't have the bundled vmware-tools installed on a ubuntu VM that matches your Linux Mint, but on a ubuntu 14.04 VM that same locate message scrolls several pages of vmware tools related files. Now it isn't how I would troubleshoot anything vmware tools related though.

Have you already ran?

  sudo apt-get install open-vm-tools open-vm-tools-desktop

At this moment I'm not sure what version of VMware Tools you have installed.

It seems like you are running open-vm-tools as your locate does not show files under /usr/lib/vmware-tools which is where the bundled vmware tools used to have a lot of its files.

But I'm also not seeing the expected open-vm-tools folders under /usr/share from your locate command, but perhaps locatedb has to be run once more.

Atm I'm slightly flabbergasted as on a debian guest of mine that I HAVE used shared folders, the shared folders now don't work..

As it turns out I had to manually run the fuse command to mount the shared folders??

sudo /usr/bin/vmhgfs-fuse /mnt/hgfs

Which then are only accessible via root (skipping the sudo part does not work on my end for whatever reason) but at least I can access the files on the share after doing this.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
Highlighted
Expert
Expert

As an experiment, I tried to create a new Linux Mint 18.3 VM in Fusion 10.1.1, of the type Ubuntu 64 bit​, without the Easy Install option; after installing, I upgraded the guest system from the Terminal:

sudo apt update

sudo apt full-upgrade

... rebooted and also ran the graphical Update Manager, which gave the option to update the kernel, which I did and then rebooted again; finally, from the Terminal:

sudo apt install open-vm-tools-desktop (which also automatically installs the base open-vm-tools package)

... rebooted, and window resizing and so on worked, while there still was no /mnt/hgfs folder; so, I also installed the VMware Tools from the Fusion menu, rebooted again (even if logging out and in again probably is sufficient), and finally also the /mnt/hgfs folder appeared (where I had my home folder shared): everything worked!

So, perhaps the best thing would be if you started over with a complete reinstall (maybe something went wrong at some point with your install?)...

Highlighted
Expert
Expert

It indeed looks like in order to automatically have your shared folders mounted at /mnt/hgfs ​for Linux guests, you also need to install the VMware Tools, after having installed the Open VM Tools: which is also what VMware still recommends in its support documents, IIRC.

Highlighted
User Moderator
User Moderator

Hi Sven,

It worked fine two weeks ago with just open-vm-tools, I didn't do anything extra back then.

Not sure why I now had to run the command to mount manually, but it certainly isn't (and shouldn't) be required to install the bundled tools for just that one feature.

The functionality is there, it just doesn't get started for whatever reason on my debian 9 vm.

To be clear I don't want the bundled tools they are a huge PITA when installing a new kernel, I want a VM without all those extra build tools that are required for the bundled install.

edit: Looks like the vmhgfs install that comes with open-vm-tools is corrupt (sigh)

So will wait until debian checks in the fix, looks like a kernel update broke the vmware shared folders...

$ sudo vmhgfs-fuse -o allow_other -o auto_unmount .host:/mnt/hgfs /mnt/hgfs

$ ls -alh /mnt/

ls: cannot access '/mnt/hgfs': No such file or directory

total 12K

drwxr-xr-x  4 root root 4.0K Mar 17 16:33 .

drwxr-xr-x 23 root root 4.0K Feb 27 13:49 ..

d?????????  ? ?    ?       ?            ? hgfs

If I unmount the /mnt/hgfs folder it is just root:root (also tried with <user>:<user>) where <user> is my user name.

Also tried via /etc/fstab

Deleted the /mnt/hgfs folder, recreated it etc.. it's a mess.

See here for tips on how it is supposed to work:

https://wiki.archlinux.org/index.php/VMware/Installing_Arch_as_a_guest#Tips_and_tricks

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
Highlighted
Enthusiast
Enthusiast

Well I have run on all the commands both of you guys have given me with no particular effect save that sudo /usr/bin/vmhgfs-fuse /mnt/hgfs gives bad mount point - no such file or directory

But I cant help but notice that you dont seem to think I SHOULD be able to share directories??? (in ubuntu, not debian)

I have only ever needed to share before in windows. It isnt possible that when I find that everything is working normally, everything IS working normally;  and ordinarily no one needs to share files between a linux vm and a host system?? 

[These are jpg files salvaged by DD_RESCUE or photorec from a fershtunkene SD which I can only recover from within a linux environment]

'cos if eveerything is working normally, a full reinstall would only be a further tail-chasing manoeuvre

0 Kudos
Highlighted
User Moderator
User Moderator

Hi,

But I cant help but notice that you dont seem to think I SHOULD be able to share directories??? (in ubuntu, not debian)

Not sure why you think that, it should just work, even with just open-vm-tools. Ubuntu / debian / mint ... it's all debian based, I just happen to like debian, but mint should work fine too, nothing wrong with that.

For /usr/bin/vmhgfs-fuse to work you need to create a mount point first.

Like in my case I created folder /mnt/hgfs (although I had that folder already from when it worked, I did delete and recreate as a troubleshooting step)

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
Highlighted
User Moderator
User Moderator

Here's another thought... did you install a graphical user interface on your VM?


Because the open-vm-tools-desktop part does depend on that....

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
Highlighted
Enthusiast
Enthusiast

WOW seems I am learning something new every day, I am grateful to you for that, - no, I have never (consciously) installed any GUI in any VM I have ever created.  If some sort of separate GUI is necessary to share files, this must be the elusive reason LinuxMint 18.3 wont share files with the host either aafter creating a new VM or after installing tools within that VM through the menu.   I was never aware this could be or should be done.  But I suppose there is a certain klunkiness about doing everything in Fusion through menus.  So if you dont mind me asking, how do I do this please and what does it do?

0 Kudos
Highlighted
User Moderator
User Moderator

Hi,

Still not sure from your reply if you have a desktop environment (GUI) installed or not, but if not then the below might help, otherwise not really.

Using just the text screens in a linux guest is a bit unfriendly as you don't even get clipboard integrations.

In that scenarion you would have depend on things like ssh in order to be able to use simple copy&paste operations.

If you have a desktop environment (the GUI) then suddenly the linux guest becomes a lot easier to use.

So there is not a special sharing GUI, but just the desktop environment in which open-vm-tools-desktop integrates.

However if you are using text only linux mint then you can add a desktop like so:

apt-get update && apt-get install mint-meta-mate

This would install the mate desktop. I'm not a mint user, but a google search tells me there's also mint-meta-kde and mint-meta-gnome if you prefer a KDE or gnome desktop.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
Highlighted
Enthusiast
Enthusiast

I have never heard of text-only linux mint? What is it? I thought people liked mint because it bore a passing resemblance to OSX?  Isnt that what a GUI is?  Weren't you talking about a Fusion GUI?

0 Kudos
Highlighted
Enthusiast
Enthusiast

I have just noticed that when I try to enable/disable sharing after changing network status from bridged to NAT, I get the error message

Unable to update run-time folder sharing status: There was an error mounting the Shared Folders file system inside the guest operating system

Does anyone think this is relevant to the problem?

0 Kudos