dsafasd33
Contributor
Contributor

"Virtual Machine is busy" on macOS Big Sur

When I try to close the window of a Virtual Machine, I encounter the following popup every time:

"The virtual machine XYZ is busy"

It doesn't matter if the VM was run or not, e.g. open settings only. I just reinstalled VMware Player again from scratch, properly removing any leftovers according to 1017838, and any VMs, and the issue persists with a brand new VM.

The temporary workaround is to force close VMware itself, which doesn't make me comfortable though.

 

macOS Big Sur 11.0.1 (20B29)

VMware Professional Version 12.1.0 (17195230)

23 Replies
dlhotka
Champion
Champion

If you're closing the window without first suspending the VM, you'll get that message while the VM suspends in the background.  That can take a long time depending on the hardware you're working on.

0 Kudos
HabibAz
Contributor
Contributor

I have the same problem. There is no apparent reason why the properly shut down machine blocks the program.

dlhotka
Champion
Champion

If it's suspended, rather than shut down, it has to dump a memory image to disk.  On a spinning disk that can take a significant amount of time.

0 Kudos
HabibAz
Contributor
Contributor

In my case it's a clean shut down switch off VM on an MacBook Pro with PCIe SSD which can do up to 1GB/s.

 

vmw1610
Contributor
Contributor

This is clearly a bug.

Since upgrading to Big Sur, I have found this to be reproducible most often when any settings are changed for a virtual machine, regardless of whether it is running or not.

I have even seen it when I first create a VM and opt to modify its settings before install. The VM has never even been started, yet it will be inoperative after its settings are updated , and attempting to quit Fusion will result in "the virtual machine foobar is busy". The only way to recover it is to force quit Fusion entirely, which is pretty drastic.

I'm sure this will be fixed in the next release, because it's not subtle and isn't hard to reproduce by anyone who uses the product for awhile.

JThom233
Contributor
Contributor

I'm also experiencing this issue on VMWare Fusion both 12.0 and 12.1. If I properly shutdown any VM and modify the VM settings, I can't start it back up without the "Virtual machine is busy" message and all settings greyed out.

I mostly notice this when expanding the disk size. The only way to resolve is to shutdown every VM and then force quit VMWare Fusion. This becomes incredibly annoying when you have 15+ VMs running on a mac host.

kghandi
Contributor
Contributor

Similar Issue. Recently upgraded to Big Sur and Fusion 12.1.0.
I get the above msg after the following sequence.
1. Shut down the guest os.
2. Reclaim disk space. Which appears to have finished.
3. Try to quit Fusion.  The above msg appears.

I also can not start the VM.

leo89
Contributor
Contributor

Same problem here. 

Shutting down the Virtual Machine successfully and getting the "Virtual Machine is busy" message. 
Also waiting a significant amount of time does not change anything. The only solution is to force kill VMware.

 

Big Sur 11.1
VMware Fusion 12.1.0

TechVM-Admin
Contributor
Contributor

This drives us crazy we have 20 VMs running. Just because one is stuck we need to kill the others to solve it all the time. We accidentally killed another one we did not intend. 

When will this be fixed? 

 

TechVM-Admin_0-1612173348592.png

 

harmv
Contributor
Contributor

Same problem here.

 

Vmware fusion 12.1.0

Host: Big Sur 11.2

client:  ubuntu 18.04, ubuntu 16.04   both show this problem

 

@VMware. Is there a bug reference/ticket number for this problem?

0 Kudos
JThom233
Contributor
Contributor

Is there even a temporary way to fix, edit or even delete a VM in the "Busy" state without having to shut everything down and restart VMware Fusion? This is a large issue for us since we're running many mac VMs used by multiple teams.

0 Kudos
JesusPresley
Contributor
Contributor

Just had this issue after an upgrade from v12.0.0 -> v12.1.0; super frustrating. It all went away after rebooting. 

@VMware: please add a message that suggests rebooting at the end of the installer. 

Sheesh

0 Kudos
PaulRaffle
Contributor
Contributor

Running Big Sur on an IMac and getting this error too!!!!!  Only thing to do is force quit.  Very frustrated.

0 Kudos
colin519
Contributor
Contributor

This continues to be a major issue.

 

MP 2019, Professional Version 12.1.0 (17195230), macOS 11.2.1 (20D74)

 

We purchased the 'Big Sur compatible' upgrade before moving to Big Sur. This version is not compatible with Big Sur as far as I can tell with this kind of problem.

0 Kudos
colin519
Contributor
Contributor

Hello all,

 

I wanted to flag this since we have a workaround that appears work.

 

We are killing the VMWare Fusion app from the Activity Monitor. This leaves any vmware-vmx processes active. I've successfully used this technique to keep a VM running while experiencing this bug while changing settings on a totally unrelated VM.

0 Kudos
colin519
Contributor
Contributor

We just did a 150GB rsync using a Mojave VM between a shared folder and a second VMDK that is attached to the VM. Killing the process using Activity Monitor did not interrupt our transfer at all.

0 Kudos
vmw1610
Contributor
Contributor

Thank you for this note.

 

Could you please clarify the steps you took? When I tested this on MacOS 11.2.2 with Fusion 12.1.0, I did Activity Monitor -> double click "VMware Fusion" -> Quit, and the result was that all VMs were suspended and VMWare exited (normal full program exit). Based on your message, I expected to find that the main VMWare Fusion process would exit without taking its guests with it.

 

0 Kudos
colin519
Contributor
Contributor

Sorry, I didn't double click. Click the X on the top bar and choose 'force quit'.

0 Kudos
mdubeau
Contributor
Contributor

Is there a fix in the works for this issue?  VMs randomly locking up and "busy" after being shut down?

0 Kudos