Cosz3
Enthusiast
Enthusiast

macOS High Sierra get "can not find a valid peer process to connect to", when startup a vm.

Hello,

I use mac High  Sierra, and download a Fusion Professional 10.0.1 for 30 days trial version. I continuously get  "can not find a valid peer process to connect to" notification, when I try to install any OS from image.

I am new to use fusion, I try to uninstall the Fusion ( both manually Manually uninstalling VMware Fusion (1017838) | VMware KB  and using cleanapp ), and reinstall the Fusion again (for multiple times), but I still get the same error.

I am so confused, I do not know where to find the log to locate to problem. Did anyone meet the same problem. please give me some help, thanks in advance.

13 Replies
wila
Leadership
Leadership

Hello,

Welcome at the VMware community forums.

This apparently happens to some people. I've not learned yet why.

The problem here is that the VMware kernel extensions are being blocked, see also:

VMware Fusion on macOS High Sierra - System Extension Blocked - PlanetVM

As I wrote in that article, if the kernel extensions block does not show up in "Security & Privacy" in macOS then most likely you can force it to show up by moving the Fusion install to another location using Finder.

Eg. Move your Fusion install from Applications to Desktop and back again.

Then check again in "Security & Privacy" and hopefully the kernel extension blockage is listed there now that so you can allow it.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
Cosz3
Enthusiast
Enthusiast

Hello wila,

Thank you very much for your timely help, It works now.

0 Kudos
cantim
Contributor
Contributor

Thanks, this worked for me, but for some reason it took a few goes to happen. I uninstalled and reinstalled and had to click on the "allow" button a good few times before it was recognised.

It felt like the control panel was not working like how it should have to "allow" the apps components to run.

So just a heads up to anyone who has tried this and it didn't work, try a few times and hopefully it will.

0 Kudos
scottweible
Contributor
Contributor

I had the same problem, although I was using an already installed High Sierra, and a brand new, never installed Fusion 10.0 Pro.  As the author suggested, I went into the Mac's Security preferences and it specifically told me it was blocking Fusion, so I unblocked it ... and after a bit of futzing to get it to work like I want, it's working fine.

0 Kudos
TECH198
Enthusiast
Enthusiast

Just out of curiosity, why would different solutions work for different OS' s relating to the same error when all you gotta do is disconnect network adapter when booting VM.  I always found this solves the issue, so will continue to use this method until it fails for me.

0 Kudos
SirRufo
Contributor
Contributor

On my Mac this does not help.

But I made a dump from the KextPolicy database (table kext_policy)

-- DUMP from kext_policy

INSERT INTO kext_policy VALUES('8J7TAMPT4P','com.vmware.kext.vmioplug.14.1.3',1,'VMware, Inc. (Fusion)',8);

INSERT INTO kext_policy VALUES('8J7TAMPT4P','com.vmware.kext.vmx86',1,'VMware, Inc. (Fusion)',8);

INSERT INTO kext_policy VALUES('8J7TAMPT4P','com.vmware.kext.vmnet',1,'VMware, Inc. (Fusion)',8);

INSERT INTO kext_policy VALUES('8J7TAMPT4P','com.vmware.kext.vmci',1,'VMware, Inc. (Fusion)',8);

INSERT INTO kext_policy VALUES('8J7TAMPT4P','com.vmware.kext.vsockets',1,'VMware, Inc. (Fusion)',8);

INSERT INTO kext_policy VALUES('EG7KH642X6','com.vmware.kext.vmci',0,'VMware, Inc.',4);

INSERT INTO kext_policy VALUES('EG7KH642X6','com.vmware.kext.vmioplug.17.1.2',0,'VMware, Inc.',4);

INSERT INTO kext_policy VALUES('EG7KH642X6','com.vmware.kext.vmx86',0,'VMware, Inc.',4);

INSERT INTO kext_policy VALUES('EG7KH642X6','com.vmware.kext.vmnet',0,'VMware, Inc.',4);

Security tab shows me that an extension from 'VMware, Inc.' was blocked but pressing the allow button will not help (change the allowed flag).

Seems macOS is confused by multiple bundle_id values

0 Kudos
ceksing
Contributor
Contributor

I can report the exact same problem.

Just purchased an upgrade to Fusion 10 version 10.0.1 downloaded

Running macOS High Sierra on a clean install. In the Security tab I also need to allow 'VMware, Inc' to run.

I have an active 'Allow' button, but multiple clicks on the 'Allow' button is just not doing anything.

So I am stuck and don't know what to do from here. Please help ?

0 Kudos
efengle
Contributor
Contributor

Until either Apple or VMware fix this problem, I have disabled "Kernel Extension User Consent" -- the new security feature in macOS 10.13 blocking the kexts.  Here are my steps.

  1. Restart Mac.  Hold Command+R at the startup chime until you see the Apple logo.  This will boot into the Recovery OS
  2. Top Menu, Select Utilities -> Terminal
  3. In Terminal, check the status Kernel Extension User Consent via “spctl kext-consent status”.  The output should say "ENABLED".
  4. To Disable, type “spctl kext-consent disable”
  5. Close Terminal.  Restart.

Note...this only turns off the "Kernel Extension User Consent" feature and nothing else.

ceksing
Contributor
Contributor

Hi efengle

Thank you so much, I can now start my virtual machines again after disabling the Kernel Extension User Consent.

I is sure not a optimal solution, but I guess I don't have a choice until the problem is fixed by Apple or VMware.

Once again I really appreciate you help on this one.

Best regards

ceksing 

0 Kudos
Yenoirb
Contributor
Contributor

Thanks efengle for the advice. I have tried everything over the last few days but this worked!  Yippee..   Is there any security risk but leaving the setting as disable?

0 Kudos
Daniel_Israel
Contributor
Contributor

I upgraded to Fusion 10.0.1 (from 8.x) and started getting this message when I started VMs. The warning and button never appeared in my "Security and Privacy" screen. Suddenly at some point it appeared, I clicked "Allow" and I was off.

Now today I'm getting the same error and the message/button are not appearing again.

Any ideas what else I could/should look for?

Thanks.

0 Kudos
richtong
Contributor
Contributor

I have the same problem. I click on the allow button but next time I reboot, I get the "can not find a valid peer process to connect to". In looking through some other threads, they suggest trying:

sudo kextutil /Applications/VMware\ Fusion.app/Contents/Library/kexts/vmmon.kext

And when I do this I get the error:

Untrusted kexts are not allowed

Kext with invalid signature (-67062) denied: /Library/StagedExtensions/System/Library/Extensions/CE647589-FEDA-442E-A17F-E60138FD4E1C.kext

Bundle (/System/Library/Extensions/HoRNDIS.kext) failed to validate, deleting: /Library/StagedExtensions/System/Library/Extensions/CE647589-FEDA-442E-A17F-E60138FD4E1C.kext

Unable to stage kext (/System/Library/Extensions/HoRNDIS.kext) to secure location.

So it seems like  the trust broke on reboot.

The other potential problem is running out of device slots. This is true with osxfuse on High Sierra, I had to unload the virtual box app and I have an expressvpn.tun that is stuck there and takes a slot, but this error looks like a problem with signing. Sigh. any ideas?

0 Kudos
PierreSt
Contributor
Contributor

I had the same problem and it was just impossible to solve. I've tried any times. So, I set the privacy and policy on "AppStore only" before moving the VMware application in a folder on the HD. The I restarted the Mac and moved the application back in the application folder. Allow the move, password… This worked well and now it is OK.

0 Kudos