Highlighted
Enthusiast
Enthusiast

macOS Catalina issue [beta]

Jump to solution

Hello.  I installed the new macOS 10.15 beta today, and loaded fusion to find that my Windows 7 VM boots up and runs just fine, but only shows a black screen. I can see it in the library and even use it by typing, moving the mouse around in the black screen, and watching in the library but that's all. Has anyone experienced this before? I've tried reinstalling Fusion, to no avail. It also doesn't show anything during post/boot, so it's not a video driver issue I don't think.

- Accelerate 3D Graphics is NOT checked.

- I receive NO error messages.

Screen Shot 2019-06-03 at 7.04.06 PM.png

57 Replies
Highlighted
Contributor
Contributor

Yea, I am on 11.1 of Fusion Pro.

I wish there was a function to manually add this permission...    

Highlighted
Contributor
Contributor

I am running Catalina beta and Fusion won't even open for me.  The icon just bounces up and down in the bottom tray and it shows application not responding.  I am forced to quit.  I have been reporting this to Apple, but no updates have come through yet.  Does anyone have a fix for this by chance?

0 Kudos
Highlighted
Contributor
Contributor

After reading this post and recommendation, I would like to share my solution.

I am running VMware Fusion 8.5 and the Screen Recording permission was never ask.

Solution :

-Install the latest version of the VMware Fusion (11.1) as trial (It will ask for Screen Recording permission)

-Close it

-Reinstall VMware Fusion that you have (Mine is 8.5)

-The Screen Recording permission is still there

-Black Screen Problem solved

Highlighted
Contributor
Contributor

Logicode - genius!  Works for me and only takes 10 minutes to download the trial and Version 8.5 (if you haven't  got the original install file).  Thankyou!

Highlighted
Contributor
Contributor

Thank you kindly Logicode.

0 Kudos
Highlighted
Contributor
Contributor

And just to confirm that the screen recording setting is maintained when upgrading from Catalina beta 3 to beta 4.

0 Kudos
Highlighted
Contributor
Contributor

This did not work, as I was already coming from VMware 11.1.

Uninstalled & reinstalled various versions between 8 & 11.1 and no luck, Screen Recording option for VMware still not there for me in System Preferences.

Only workaround for me at this point is the VNC into the VM session to see the virtual OS screen, which is additionally slower.

0 Kudos
Highlighted
Contributor
Contributor

If you're desperate you could create another user account on your mac and install your copy of fusion 11.1 into that. You should get the security prompt then.

0 Kudos
Highlighted
Contributor
Contributor

This worked for me going from v10 to 11 and back.

NB I had an issue with being unable to install the v10 .dmg downloaded from vmware (after using the v11 to get the screen recording prompt to show), but just did a hotspot drop of another copy of v10 from another computer and that worked out OK.

0 Kudos
Highlighted
Contributor
Contributor

In my case it was not listed in "Security & Privacy -> Screen Recording". After much searching and testing what worked for me is:

  1. Boot a VM with an OS that has VMware Tools installed (after the VM fully boots the ability to switch to Unity mode should be available)
  2. Switch to Unity mode
    • Keyboard command to enter Unity :     Shift-CMD-U
    • Menu : View -> Unity
  3. Upon switching to UNITY mode VMware Fusion will finally give you the dialogue box asking permission for Screen Recording
    • ScreenShot-Prefs.png
  4. Click Open Preferences
  5. Authenticate to make changes
  6. Add the check mark to VMware Fusion to grant Screen Recording permission
    • ScreenShot-ScrenRecord.png
  7. Exit Unity mode

Done

Additional notes:

VMware may continues to go to Unity mode before you can select Open Preferences and give you white screens. The presentation is white because it has not been granted permission yet.

From the VMware controls, shut down the VM gracefully. The Open Preferences should still be an open dialogue. Click Open Preferences and it will finally be visible in the list.

For the adventurous, try resetting all of the TCC approvals for VMware Fusion and try again.

To reset the TCC, open a terminal and run the command:

tccutil reset All com.vmware.fusion

successfully reset All approval status for com.vmware.fusion

This clears the Security and Privacy settings.

Hope this helps.

Highlighted
Contributor
Contributor

Thank you VirtuallyHuman, finally resolved! :smileygrin:

I had to do both this Unity mode workaround to get the Screen Recording privacy option enabled.

And then also run this command in Terminal-

defaults write -g NSRequiresAquaSystemAppearance -bool Yes

Highlighted
Contributor
Contributor

Updating from 11.0 to the latest VMware fusion 11.1 helped me.

I did these steps:

1) Download new fusion from VMware website

2) Install it over old version

3) Start your VM and confirm all security requests.

0 Kudos
Highlighted
Contributor
Contributor

it's really helpful.

My Fusion is 10, when I install 11 trial, the Screen Recording permission popup.

Now, I'm reinstalling Fusion 10. Thanks a lot.

0 Kudos
Highlighted
Contributor
Contributor

In another thread, ProjectFlameX​ has another solution which worked for me.  One recommendation though...  Run each of the commands individually as some of them will need a password.

Hey guys.

After hours of research this solution works for me:

1. Install VMWare.

2. Restart computer and go to Recovery Mode (hold CMD+R when computer starts until you see an Apple logo).

3. Go to top menu and choose Utilities and then Terminal.

4. Turn off SIP with this command:

     csrutil disable

5. Go to top menu and choose Apple Logo and the Restart.

6. After macOS starts normally open /Applications/Utilities/Terminal.app and paste this commands:

     tccutil reset All com.vmware.fusion

     sudo sqlite3 "/Library/Application Support/com.apple.TCC/TCC.db" 'insert into access values ("kTCCServiceScreenCapture", "com.vmware.fusion", 0, 1, 1, "", "", "", "UNUSED", "", 0,1565595574)'

     sudo sqlite3 "/Library/Application Support/com.apple.TCC/TCC.db" 'insert into access values ("kTCCServiceListenEvent", "com.vmware.fusion", 0, 1, 1, "", "", "", "UNUSED", "", 0,1565595574)'

     sudo sqlite3 "/Library/Application Support/com.apple.TCC/TCC.db" 'insert into access values ("kTCCServicePostEvent", "com.vmware.fusion", 0, 1, 1, "", "", "", "UNUSED", "", 0,1565595574)'

7. Go to Recovery Mode (hold CMD+R when computer starts until you see an Apple logo).

8. Go to top menu and choose Utilities and then Terminal.

9. Turn on SIP with this command:

     csrutil enable

10. Restart.

Highlighted
Contributor
Contributor

sudo sqlite3 "/Library/Application Support/com.apple.TCC/TCC.db" 'insert into access values ("kTCCServiceScreenCapture", "com.vmware.fusion", 0, 1, 1, "", "", "", "UNUSED", "", 0,1565595574)'

Fixed it! 🙂 Back in business 🙂

Highlighted
Contributor
Contributor

Thank you.   That was a life saver.  Prior to this I could not get fusion into the Privacy->Screen Recording settings so the console would stop displaying all black.  Back in business.

0 Kudos
Highlighted
Contributor
Contributor

Thanks!  This worked wonderfully for me.   I recently purchased Fusion for my iMac Pro, running Mojave.  Loving it, I also loaded it onto my 2014 MacBook Pro, on which I am testing Catalina DP 6.  Until I found your solution, I too was getting the black screen, with nothing listed in Screen Recording.

What I am now finding is that when I launch a VM, I get a complaint that it wants to be enabled in Accessibility.  I try to do this but, even after unlocking System Preferences, the check box does not receive the click and remains unchecked.  That being said, the Ubuntu VM, that I'd set up, seems to run nominally.

0 Kudos
Highlighted
Contributor
Contributor

You don't need to turn SIP off to do this.

The Recovery Partition is SIPless.  csrutil will report SIP on in recovery but its not, the Kernal for recovery has been compiled with SIP disabled.

You can simply do :-

"/Volumes/Macintosh HD/usr/bin/sqlite3" "/Volumes/Macintosh HD/Library/Application Support/com.apple.TCC/TCC.db" 'insert into access values ("kTCCServiceScreenCapture", "com.vmware.fusion", 0, 1, 1, "", "", "", "UNUSED", "", 0,1565595574)'

"/Volumes/Macintosh HD/usr/bin/sqlite3" "/Volumes/Macintosh HD/Library/Application Support/com.apple.TCC/TCC.db" 'insert into access values ("kTCCServiceListenEvent", "com.vmware.fusion", 0, 1, 1, "", "", "", "UNUSED", "", 0,1565595574)'

"/Volumes/Macintosh HD/usr/bin/sqlite3" "/Volumes/Macintosh HD/Library/Application Support/com.apple.TCC/TCC.db" 'insert into access values ("kTCCServicePostEvent", "com.vmware.fusion", 0, 1, 1, "", "", "", "UNUSED", "", 0,1565595574)'

while in Recovery to directly alter the TCC database on your system drive.  NOTE: Im assuming your system HD name is "Macintosh HD"  if not change it in the example.

Highlighted
Contributor
Contributor

Hi,

all workarounds in this thread (so far) didnt worked out for me.

Found a Solution.

1) Remove VMware Fusion 11.1.1 from MacOS Catalina Beta

2) Install VMware Fusion 11.1.0

3) Start any VM

4) See the popup asking for screen recording permission.

5) Grant permission and see VM-desktops Smiley Happy

Best Regards

Highlighted
Contributor
Contributor

Same for me. Nothing to select in Screen Recording dialog.

0 Kudos