om3rx
Contributor
Contributor

macOS Big Sur Fusion 12 NAT no internet connection

Hi,

Running latest macOS Big Sur with Fusion 12. Nothing changed in my virtual machine Windows 10 however internet connection is not working

107 Replies
redhatter9
Contributor
Contributor

Same problem as @michaelw1998  described - No VPN is involved and broken networking in VM (NAT "Share with my Mac" mode). The RHEL VM can't even ping the gateway although DHCP properly assigns gateway, DNS & IP and routing and ARP look fine. Cannot ping anything other than self IP in VM (same result with statically assigned IP).

This suggests a problem with NAT/gateway server virtualization on host. Running tcpdump on the host against bridge100 interface shows traffic leaving with VM's IP as source but no response from the gateway or anything beyond.

I have reviewed the workarounds posted in the forum, but nothing applies to my situation. Networking is totally broken at IP layer level. If anyone has made progress with this situation, kindly share.

0 Kudos
BlazerChad
Contributor
Contributor

So, I just did this and answered my own question. 

 

Trashing/reinstalling Fusion 12 with Cisco AnyConnect disconnected fixed this issue for me.

0 Kudos
BlazerChad
Contributor
Contributor

Scratch that, back to square one after connecting to vpn.

0 Kudos
redhatter9
Contributor
Contributor

I completely uninstalled it (as noted here https://kb.vmware.com/s/article/1017838 ) and reinstalled (Cisco AnyConnect not running), but to no improvement.

0 Kudos
calebxin
Contributor
Contributor

experiencing the same problem, internet is working but VPN doesn't work.

0 Kudos
andyfisher100
Contributor
Contributor

I have the same issue.

Everything worked perfectly on Catalina + Fusion 11 but its totally broken after the upgrade to Big Sur and Fusion 12. Whilst i do have Cisco AnyConnect installed, i experience the same behaviour when both connected and disconnected to the VPN

0 Kudos
gsulshski
Contributor
Contributor

I have the same symptoms as I see in this thread:

 

Big Sur Fusion 12 NAT --> no internet connection

changed to bridged and I can get wireless (my mac is wired..but whatever) internet connection

In bridge,  with cisco anyconnect 4.9.01905...  VPN fails with authentication failed message.

0 Kudos
fix2k5
Contributor
Contributor

My VM (win10) does not have internet connection in any mode NAT or bridged now. It was working for a while (don't remember if NAT/bridged) but then i added new VPN connection (mac built-in) and since that time i VM internet connection failed. I'm not 100% sure if this was the trigger, but at least i noticed the problem after these changes.

I also tried to use the same VM in Parallels 16.1 and got problem with network adapter during startup (no internet again in VM). So, apparently something is not right on my mac host. However, in parallels forum there was a recommendation about changing some parameter in parallels config that triggered "system extension blocked" dialog. Once i enabled it, my VM had network connectivity right away.

As i'm not an expert in this area, but i thought that these extensions are deprecated in Big Sur, but somehow this change fixed the issue with Parallels at least.

Considering this, I think that similar issue is with Fusion (i'm running latest 12.1) that it somehow can't handle new way of operation (macos apis) and perhaps can't deal with my mac host network or something about that. I have multiple VPNs defined in my host; at the same time even if everything is turned off, guest VM don't have internet anyway.

0 Kudos
JoshCastro
Contributor
Contributor

Not sure if this will solve for all but here it is. I have been working on this issue for a while and could not get it figured out. Then with one click I was back on my VPN. In the Mac settings go to Security and Privacy and go to Firewall and turn on Firewall options. Then turn off Stealth mode. With that one click I was back up and using the VPN.

0 Kudos
MaverickAdmin
Contributor
Contributor


@JoshCastro wrote:

Not sure if this will solve for all but here it is. I have been working on this issue for a while and could not get it figured out. Then with one click I was back on my VPN. In the Mac settings go to Security and Privacy and go to Firewall and turn on Firewall options. Then turn off Stealth mode. With that one click I was back up and using the VPN.


Mine wasn't enabled. And the VPN/NAT'ing hasn't worked ever since the upgrade to macOS Big Sur (11).

Egonj
Contributor
Contributor

Check your Antivirus software if you have any?

I had the same issue, it turned out to be Kaspersky Internet Security. The newest version has some network monitoring tools that get installed and they kill the VM's network access. After uninstalling KIS, my networking immediately started working again.

0 Kudos
topher800
Contributor
Contributor

I have this similar problem.

Once VPN is established there is no internet on any VM guest, CentOS 7&8, Windows10, and Ubuntu 16.04.  Except that DNS works; if I nslookup or ping a host, I get an IP back.

Company computer MBP with Catalina, Fusion 12.1, Global Protect VPN.  This works fine.

Personal computer was the same as above, except upgraded to Big Sur.  This worked prior to the upgrades, but now has the VPN established issue with guest OS's

Both are operating via WiFi, not hard ethernet cable.   VMWare guest OS network settings show "Share with my Mac" selected.

I do not have to restart anything once I terminate the VPN session, guest OS's just start working.

0 Kudos
topher800
Contributor
Contributor

You don't say what the status is if step 3 succeeds, but step 4 fails.

0 Kudos
wd123
Enthusiast
Enthusiast

@topher800 I'm assuming you're referring to my message?

If so, that's because I can't imagine a scenario where steps 1-3 all succeed, but 4 fails.

  1. Confirms VM web (port 80) connectivity.
  2. Confirms VM ability to do a DNS lookup to an external host.
  3. Confirms VM ability to do a DNS lookup on your local VM network.
  4. Is a combination of step 1. and 3.

Given that step 4 is just a combination of steps 1 and 3 in one step, I struggle to think of a case where steps 1-3 all work, but 4 does not.  I'd need more details to provide help here...

0 Kudos
scandey
Contributor
Contributor

I am also experiencing this issue (Host: Mac OS 11.1, VMware Fusion: 12.1.0, Client: Windows 10 fully updated). I've locked the issue down to my use of Cisco Anyconnect Secure Mobility Client. When the Cisco VPN software is opened or running on the host (regardless of connection status) when the Windows VM boots up, the network connection is broken (with the exception of DNS for some reason). If I quit Cisco on the host and shutdown the Windows VM and start it up again, I have no issues sharing non-VPN internet with the VM. Note that for me, restarting Windows within the VM does not seem to work consistently, it needs to be fully shut down and started up again. 

In my case the solution was just to redownload and run the Cisco VPN software within the client as suggested by VMware, but this is not a long term fix and likely would not work for people who need to have A) a separate VPN service for the client while still needing Cisco VPN on the host or B) be able to access the Cisco VPN on both host and client at the same time. For other employees of my organization, both cases are often required and so this is a huge issue! 

0 Kudos
Imodos
Contributor
Contributor

0 Kudos
michaelw1998
Contributor
Contributor

I am not using any VPN so the above "solution" doesn't work.

When will VMware finally step in to fix this matter? Or are they just waiting for everyone to switch to Parallels as internet just works fine there... 

0 Kudos
topher800
Contributor
Contributor

@wd123

Yes I was referring to your message.  My apologies, I missed that step 1 was testing a connection.  I must have assumed a logical progression.  That aside.  Steps 1&4 are failing, steps 2&3 are working.

 

0 Kudos
topher800
Contributor
Contributor

0 Kudos
GreggShephard
Contributor
Contributor

I can't connected to the internet either.

I don't use Cisco AnyConnect though

VM needs to fix this 

 
 
0 Kudos