Highlighted
Contributor
Contributor

macOS Big Sur Fusion 12 NAT no internet connection

Hi,

Running latest macOS Big Sur with Fusion 12. Nothing changed in my virtual machine Windows 10 however internet connection is not working

54 Replies
Highlighted
Contributor
Contributor

Am I missing anything?

 

Thank you again.

0 Kudos
Highlighted
Enthusiast
Enthusiast

Its a problem of Fusion in combination with Big Sur (due to Apple dropping support for kernel extensions, VMware had to find other means to establish virtual networks - and Apple left only very few limited options).

From my standpoint the simplest workaround is just to ignore DHCP and configure IP manually. So for example if your subnet for the VM is 192.168.77.0/24, configure something like 192.168.77.20 as the IP for your guest and use 255.255.255.0 (or 24) as subnet mask (or prefix length) and usually 192.168.77.1 as gateway/router and also for DNS and maybe WINS. If your OS requires an explicit broadcast address, use 192.168.77.255 (for the mentioned sample subnet). That's about it.

When you have multiple VMs that should be able to talk to each other, manually assign them IPs like above, but avoid the IPs .0, .1, .2, and .255.

Be aware not to simple use the numbers mentioned here! Adapt the subnet 192.168.77.0 to your needs and current configuration of Fusion! Sadly, the Fusion UI hides all of these details. So have a look at the file /Library/Preferences/VMware\ Fusion/networking and use the value set for VNET_8_HOSTONLY_SUBNET. Or start your VM and inspect the IP configuration set (even if DNS resolution does not work, the basic configuration at least of the subnet will be correct).

0 Kudos
Highlighted
Contributor
Contributor

I have the Problem with Bridged after coming back from sleep Mode of my Mac Book.

All VM have no Network(Internet, LAN)

I have to restart the complete VMWare Fusion 12 then the VM reconnect.

0 Kudos
Highlighted
VMware Employee
VMware Employee

Hi om3rx,

Did your Windows 10 VM get other network information correctly? say, what's the IP address of the VM. Could you please help to upload the nat.conf resides in /Library/Preferences/VMware Fusion/vmnet8/nat.conf and vmware.log in the VM bundle? You can get vmware.log through below steps:

1.Right click the VM name on VM window

2.Click the path next to the VM name(location where VM resides) in the menu item list.

3.Right click the VM name in Finder and select 'Show Package Contents'

4.Navigate to vmware.log and upload it 🙂

And then please try the following steps and check if the network could work:

1.Shutdown the Windows 10 VM.

2.Quit Fusion.

3.Re-launch Fusion and start up the Windows 10 VM

0 Kudos
Highlighted
VMware Employee
VMware Employee

Hi,

What's the output of command 'ifconfig' on your Big Sur host when this issue occur? Is there any error message?

0 Kudos
Highlighted
VMware Employee
VMware Employee

Did you try disconnect/reconnect the vm network adapter?

0 Kudos
Highlighted
Contributor
Contributor

Same issue when using Internet Sharing network adapter on BigSur with Fusion 12.0.0.

Noticed that the default gateway has changed from .2 to .1

Seem to have a workaround - created a new custom network with the same subnet as used with Internet Sharing. Switched all VMs to use that custom network, and they seem to work out of the box with DHCP. 

Need static IP's for my use case so have assigned those for all VM's.

0 Kudos
Highlighted
Contributor
Contributor

I checked the network IP addresses at the vmnet8/networking file.

I set my network settings in my VM accordingly but the VM still doesn't work with internet (NAT).

Here are my settings: 

0 Kudos
Highlighted
VMware Employee
VMware Employee

Hi 

Did you set static IP for your VM?

0 Kudos
Highlighted
Contributor
Contributor

Hi nancyz,

As you can see in the screenshot I attached to my post, yes I did set a static IP in my VM.

It doesn't work.

Can you tell if VMware is working on a proper fix?

0 Kudos
Highlighted
VMware Employee
VMware Employee

Hi,

Yes, there are a few differences on Big Sur host. 'X.X.X.1' will be used as the default gateway and dns for NAT VMs. But the default NAT network should work after upgrading if they were set to use DHCP(by using .1 as default gateway and dns). 

0 Kudos
Highlighted
Enthusiast
Enthusiast

Hi nancyz.

It seems, if you have manually adjusted something for the network settings (like manually selected subnet, configured some static IPs for DHCP etc.), the upgrade cannot handle this. In my case, after upgrading to Big Sur and then doing the upgrade from Fusion 11 to 12, the NAT server moved from .2 to .1 but DHCP still announces .2 as DNS server (but the gateway was correct). And I found no way to fix the erroneous DHCP announcements (so my only solution has been to fall back to static IP config, giving up on DHCP).

0 Kudos
Highlighted
Contributor
Contributor

Hi @snobis ,

I set the VM to automatically get network information. I noticed it got the IP address 192.168.206.5 and gateway 192.168.206.1 which seems correct.

However, when pinging the gateway it still says request timed out so it doesn't even work locally without DNS...

 

@nancyz to be clear about my situation: I installed VMware Fusion 12 for the first time, I haven't used 11 or any other version so for me there wasn't any upgrade at all.

I've attached another screenshot.

0 Kudos
Highlighted
Enthusiast
Enthusiast

Hi michalw1998.

If you have a new, fresh installation of Fusion there should be no problem with DHCP.

I think you have some other networking problem. Maybe any kind of firewalls that are wrongly configured (Windows Firewall inside the guest, MacOS Firewall (though the default configuration should be fine) and/or some other host firewall like Little Snitch). When I debug networking problems, my first step is to stop any other activities (mainly due to security concerns) and deactivate any kind of firewalls. Another tool that might be helpful is tcpdump or wireshark - but if you do not know these tools I'm afraid you have not much background in networking and they might overwhelm you. Oh, and after debugging the problem, do not forget to activate any security measures you deactivated (turning on all firewalls etc.), before resuming normal activities. 🙂

Sorry, if this is not too helpful. Maybe someone else has a bit more time and resources to help or maybe you find someone with more detailed networking knowledge among your friends/colleagues.

0 Kudos
Highlighted
Enthusiast
Enthusiast

For anybody experiencing DNS-level problems in a VM using a NAT adapter (that is, IP-level stuff is fine, but no name will resolve via DNS), I've posted a workaround in https://communities.vmware.com/t5/VMware-Fusion-Discussions/DNS-Forwarder-Does-Not-Seem-to-Exist-in-...

Due to network-level changes in how VMware Fusion operates on Big Sur, it is now necessary to ensure that nothing is listening on port 53 on your host, regardless of scope.  Either that or just configure each guest VM with a manual address for a DNS server, rather than have it use what DHCP says it should.

 

0 Kudos
Highlighted
Contributor
Contributor

I have exactly the same problem!!!! OpenVPN network works in Big Sur but not in Linux/Windows Virtual Machine over NAT, the traffic routed form the Virtual Machine to the VPN network does not work since I upgraded to BigSure.

0 Kudos
Highlighted
Contributor
Contributor

The problem is with Apple(macOS) Fusion12(VMware) or Cisco AnyConnect VPN(Cisco) ?

I tested with my personal MacBook Pro at home. Running macOS Big Sur without any VPN clients. Loaded Windows 10 VM with Fusion12 NAT works without problem..

At work I have same setup except my host macOS Big Sur has Cisco AnyConnect.. but NAT is not working...

 

0 Kudos
Highlighted
Contributor
Contributor

I am having similar issue with macOS Big Sur, Fusion 12 NAT connection and Cisco VPN, following this thread for a solution. Let me know if I can contribute by providing more info/ testing anything.

0 Kudos
Highlighted
Enthusiast
Enthusiast

/me grumbles about disappearing messages on this forum.   One more time...

@om3rx Some VPN configurations prevent any other network communications, which may even interfere with VMs being able to communicate.  But that depends on the VPN.

If you want to test whether your connectivity problems lie on the IP layer or name resolution layer, you can try a few steps from a guest VM:

  1. curl 172.217.13.238
    This should return something like:

    <HTML><HEAD><meta http-equiv="content-type" content="text/html;charset=utf-8">
    <TITLE>301 Moved</TITLE></HEAD><BODY>
    <H1>301 Moved</H1>
    The document has moved
    <A HREF="http://www.google.com/">here</A>.
    </BODY></HTML>

  2. nslookup www.google.com 8.8.8.8
    This should return something like:

    Server: 8.8.8.8
    Address: 8.8.8.8#53

    Non-authoritative answer:
    Name: www.google.com
    Address: 172.217.15.68
    Name: www.google.com
    Address: 2607:f8b0:4004:80a::2004



  3. nslookup www.google.com
    This should return something like:

    Server: 8.8.8.8
    Address: 8.8.8.8#53

    Non-authoritative answer:
    Name: www.google.com
    Address: 172.217.15.68
    Name: www.google.com
    Address: 2607:f8b0:4004:80a::2004

  4. curl www.google.com
    This should return an HTML document that is mostly JSON.

    ... <snip>
    google.pmc=JSON.parse(pmc);})();</script> </body></html>

 

If you got through step 4, congratulations.  Everything is working fine.
If step 3 was the first to fail, then I suspect that you have the DNS-layer problem described elsewhere. This is VMware's fault.
If step 2 was the first to fail, then you have some IP-layer trouble. Specifically, your network isn't allowing outbound DNS requests. If you have a VPN at play on your host, see this workaround.
If step 1 was the first to fail, then you have IP-layer trouble. Specifically, your network isn't allowing outbound web requests. If you have a VPN at play on your host, see this workaround.

It's hard to point a finger at who is to blame for this mess.  One one hand, Apple apparently changed how NAT networking can be achieved with a virtualization product.  On the other hand, VMware failed to plan-for/test real-world networking configurations.  e.g., What if the host OS has something already listening on port 53 on any interface?  Or what if the host OS has a VPN connection?

0 Kudos
Highlighted
Contributor
Contributor