davisford
Contributor
Contributor

can't enable hgfs in host?

Hey, I d/l one of the pre-made appliances from vmware site - ubuntu 7.10 desktop.

I fire it up in VMWare Fusion, and I want to copy some files over to it. So I enable a shared folder.

Then I do this:

sudo mount -a

Error: cannot mount filesystem: Protocol error

tail /var/log/messages

Dec 21 10:48:08 ubuntu710desktop kernel: http://3557.993399 VMware hgfs: HGFS is disabled in the host

So, I go back to settings, and try to enable it. Every time I click Enable, and then Apply, the check-mark disappears. Enabled at Power on Is enabled and sticks, and my specific share folder is enabled.

I tried updating to the latest VMware tools, and i tried rebooting the Ubuntu instance...nothing sticks.

Any clue? Doesn't seem like I can enable shared folders??? Why?

0 Kudos
6 Replies
rcardona2k
Immortal
Immortal

There is a bug I've read here that the check box for enabling Shared Folder may not stick (requires multiple attempts). If this is not your problem, also check to make sure you don't have this line the .vmx configuration file:

isolation.tools.hgfs.disable = "TRUE"

Either delete it or change it to FALSE while the VM is turned off, then restart the VM.

davisford
Contributor
Contributor

Thanks for the tip. I did check and that particular line in the .vmx file is set to FALSE already.

I have tried multiple times - rebooting the OS, re-setting the check-box, Ok/Apply multiple times.

It does not seem to work.

Is there no other workaround? Do I have to wait for the next bug release?

The version I have is Fusion 1.1 (62573)

0 Kudos
rcardona2k
Immortal
Immortal

I've never paid attention to the Enabled flag in the GUI but it acts as a status indicator more than a setting. When a VM is powered off "Enabled" is unchecked and nothing I do can change that. The checkbox that changes anything for me is "enabled at power on". I started by toggling the value above to TRUE to disable hfgs and I get the error you have. If I enable Shared Folders with "enabled at power on" while the VM is running, then "mount /mnt/hgfs" returns either protocol error or error canonicalizing the path.

Once I have "enable at power on" checked and at least one shared folder set to "enabled", upon the next reboot, then sudo mount /mnt/hgfs works for me and the status of "Enabled" on the Shared Folder item goes to the checked status.

Hope some of this make sense.

edit: damaged tools?

Another thought that occurred to me is you may have outdated or damaged VMware Tools whose hgfs driver does not work. You would have to through the Virtual Machine > Install VMware Tools path to mount /media/cdrom and apply the latest tar file for the VMware Tools.

0 Kudos
davisford
Contributor
Contributor

Thanks again for tips.

It fixed itself. I have no idea why, but all I did was suspend the VM, then re-play it, and the protocol error went away, and the check-box says enabled. No clue what the difference is/was -- I tried rebooting the VM from inside the OS several times, and this never worked. Only suspend/resume worked. It wasn't damaged tools, b/c I also updated tools to the latest.

Hope it helps someone.

0 Kudos
alvillarica
Contributor
Contributor

This tip helped me. I tried rebooting, etc. The only thing that fixed it was a suspend/resume.

Al

0 Kudos
samiller
Contributor
Contributor

I had a similar problem with a Windows XP virtual machine. Suspending it, waiting a few seconds then resuming it worked like a charm. Thanks for an off-the-wall but brilliant solution, davisford! I'm running VMWare Fusion 1.1.3 (94249) on an iMac with OS 10.4.11

0 Kudos