jasimon9
Contributor
Contributor

XP VM stops allowing copy/paste between VM and host

I have easily used the clipboard operations between the host and VM XP  since starting with VMWare, but all of a sudden I am having a lot of  difficulty.

I have not made any settings changes relating to clipboard copy/paste for so long, I don't even remember where such things are controlled. I looked in both VMWare Preferences and VM Settings (Sharing) and nothing jumps out as relevant.

The issue is somewhat intermittent, in that sometimes it works, but most of the time it does not.

What controls this and how can I fix it?

0 Kudos
2 Replies
gbullman
Expert
Expert

If I were experiencing an issue like that I would uninstall and re-install the latest VMware Tools.  Tools basically is all of the guest / host integration so always worth a shot when having problems in that area.  I've never encountered a downside from re-installing Tools, just ignore any Hardware wizards after the VM boots up after the uninstall.

I continue to use copy / paste between XP SP3 VMs and my 10.6.6 Mac.  I'm running Fusion 3.1.2 with tools 8.4.5

0 Kudos
jasimon9
Contributor
Contributor

I read somewhere that a possible workaround is to set the VM to not start automatically upon start of VMWare, and just wait a minute before starting it.

I tried this, and on the next start of VMWare, after starting the VM I tested copy/paste both ways. This time it worked.

Since the problem is intermittent, I am not sure if this is a solid workaround yet.

I also noticed that I posted this same question again 3 weeks later after starting this one.

0 Kudos