Windows XP VM - no keyboard input

I have an issue with a Windows XP virtual machine I created by converting a GHO image to a VMDK file.

Initially there was no keyboard input but the mouse worked (piggy-backed through the keyboard). Did a bit of searching and came accross threads from years ago that mentioned Firefox and other applications causing issues but I put the same VM on a clean install of Mac OS and the same problem was present.

I added usb.generic.allowHID = "TRUE" to the configuration file and, with the assistance of an additional (generic HP) USB keyboard, I was able to manually connect the Apple keyboard which allowed me to log in, Windows detected and installed the keyboard and I was also able to install VMware Tools.

So now I've got a situation where I can manually connect the keyboard but it's not auto-grabbing/releasing like the mouse is.

At some point in tweaking the VMX file, I've noticed the following lines are appearing in the log alongside similar messages for the mouse, which makes me think something simple is missing that will completely resolve the issue.

keyboard| I120: VTHREAD start thread 11 "keyboard" pid 3274

keyboard| I120: Forgetting VThreadID 11 ("keyboard")

I've attached a text file containing lines from the VMX file and an extract from the log when I manually connect the keyboard.

I've created VMs from existing images before (and created a Windows 7 VM via the same method, GHO to VMDK conversion) and never had a problem like this. If anyone has a solution or any suggestions as to what may resolve the issue, it would be much appreciated.


Host: iMac 20" (Mid 2010), Mac OS X Snow Leopard (fully patched to 10.6.8), VMware Fusion 4 (patched to 4.1.3)

Guest: Windows XP Pro (Service Pack 3)

0 Kudos
1 Reply

The answer wasn't in the VM configuration at all... it was a pesky yellow exclamation mark on the device "Standard 101/102-Key or Microsoft Natural PS/2 Keyboard".

The fix required a little registry tweak:

Navigate to HKLM\System\CurrentControlSet\Services\i8042prt

Set the "Start" DWORD value to "1" (Base: Hexadecimal) which sets the i8042 (keyboard/mouse controller) device to autostart.

Then all I had to do was restart the VM.

Not sure why that caused problems with the keyboard but not the mouse but doesn't matter, problem solved! Smiley Happy

0 Kudos