VMware Communities
pbyhistorian
Contributor
Contributor

Windows 7 guest has black screen on startup, but screen is visible in Virtual Machine Library

I'm running Fusion 7 on a Macbook Pro running OS X Yosemite (10.10.5).

My most important Win 7 guest now shows only a black screen on startup.  I can watch the VM start up and shut down in the Virtual Machine Library, but I have black screen and apparently no keyboard input on the VM.

Trying the various startup options (Safe Mode, Safe Mode w/Networking, Safe Mode w/Command Prompt, Start Windows Normally) has the same result.

Before consolidating the hard drive, I could get the GUI by switching to the initial startup snapshot.

Also, booting of the Windows 7 CD and selecting "Repair" says there's nothing wrong.  I can mount (a copy of) the drive in another VM and everything appears to be there.  All I have to do is remember everything I ever installed and re-install it.

Or maybe someone knows why the screen is blank?

Reply
0 Kudos
2 Replies
Mikero
Community Manager
Community Manager

Hm, weird.

Have you tried toggling between the view modes?

-
Michael Roy - Product Marketing Engineer: Fusion & Workstation
Reply
0 Kudos
dave1992
Contributor
Contributor

I have a very similar problem, with a Windows 7 guest and a Linux VM. Both are visible in the Virtual machine library, both are black screens in the separate VM window. Both display properly in that VM window when suspending, suspended or restoring, but when running, go blank. The blank window does accept keyboard and mouse, and I can see what is happening on the library window. Full screen and single window have the same problem. The windows VM works properly in Unity mode. The Linux box doesn't support Unity mode.

I'm running VMFusion 7.1.3, on a MAC running OS 10.10.5. I cannot upgrade either of those because of work policy.

I tried switching on/off 3D Acceleration and retina settings in Display - didn't help.

many thanks

Dave

Reply
0 Kudos